Problème webcam Skype avec ubuntu 9.10

Résolu/Fermé
Inceptor - 2 nov. 2009 à 20:32
 Cedemx - 23 mars 2010 à 17:06
Bonjour à tous,

J'essaie de faire fonctionner ma webcam sur Skype avec ubuntu 9.10, le problème est que mon image est verte avec des lignes mais je me vois quand même un peu! Ce n'est pas la même erreur que celle qui est décrite ici:

http://forum.ubuntu-fr.org/viewtopic.php?id=264606

La solution de marcdima fonctionne un peu mais pas suffisamment, je m'explique: Au début j'avais rien du tout comme image, j'ai suivi la solution et maintenant je me vois un peu mais a double et tout reste très vert (inutiliable)

En cherchant un peu, j ai remarquer que la solution faisait intervenir v4l comme librairie pour la caméra mais si je vais dans gstreamer-properties ma caméra ne fonctionne pas avec v4l (l'image est verte) tandis qu'elle fonctionne avec v4l2.

J'ai essayer plusieurs solution pour charger cette librairie a la place mais rien ne marche, j'ai comme librairie dans mes dossiers:
usr/lib/libv4l/v4l1compat.so
usr/lib/libv4l/v4l2convert.so
usr/lib/libv4l1.so.0
usr/lib/libv4l2.so.0
usr/lib/libv4lconvert.so.0

Je suppose que les "convert" doivent être la solution à mes problèmes, je pense en effet que je charge la mauvaise librairies en lançant skype... (En passant, c'est quoi les libs avec des .0 à la fin?)

J'ai essayé plusieurs solution dont par exemple : (ci-dessous le texte du script lancé automatiquement, voir solution marcdima)

#!/bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so:/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

Encore une chose, ma webcam est : ID 093a:2621 Pixart Imaging, Inc.

Voila, donc je demande votre aide...

Merci d'avance!

Inceptor

6 réponses

mamiemando
Messages postés
31212
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 juillet 2022
7 370
3 nov. 2009 à 19:32
J'ai essayer de charger la lib v4lcompat et/ou l'autre chose "LIB_SKIP_ARGB_VISUALS=1" pour les deux version de skype (2.0 et 2.1), ce qui est bizarre c'est que linux reconnait bien ma webcam, je peux la voir avec gstreamer ou enregistrer des images avec vgrabbj...

J'aurais plutôt tenté :

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype


Vérifie que le fichier en question existe bien :

ls -l /usr/lib32/libv4l/v4l1compat.so


Ça pourrait marcher ?

Dans l'absolu oui (même si c'est gore)... si on pouvait modifier les sources de skype :-) C'est l'éternel problème avec les logiciels propriétaires, quand ça déconne on ne peut pas faire grand chose à part éplucher les forums en espérant que quelqu'un ait déjà rencontré et résolu le problème.

Ma copine aimerait bien me voir...

Tu ferais mieux de prendre un billet de train :-)

Bonne chance
2
Malheureusement rien ne va...

Je vais essayer la solution "gore" demain!

Ah c est chiant tout ca!

Merci bien de ton aide en ton cas,
Bonne soirée
0
mamiemando
Messages postés
31212
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 juillet 2022
7 370
3 nov. 2009 à 00:36
On dirait que ça ressemble à ce qui est dans la documentation :-) On aura beau dire, ubuntu c'est quand même bien fait ^^
http://doc.ubuntu-fr.org/skype#webcam_image_verte

Bonne chance
0
Hello,

Non ce n'est pas exactement le même problème, j'avais au début uniquement une image fixe verte et après l'application des librairies, je me vois un peu... Je me vois même trois fois superposer, le tout sur un fond vert...

Il y a surement quelque chose d'autre que je dois faire...

Merci d'avance
0
mamiemando
Messages postés
31212
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 juillet 2022
7 370
3 nov. 2009 à 19:05
Certes, mais ça sent quand même la webcam mal prise en charge, tu devrais tenter le coup je pense.
0
tanté le coup? lequel ?

J'ai essayer de charger la lib v4lcompat et/ou l'autre chose "LIB_SKIP_ARGB_VISUALS=1" pour les deux version de skype (2.0 et 2.1), ce qui est bizarre c'est que linux reconnait bien ma webcam, je peux la voir avec gstreamer ou enregistrer des images avec vgrabbj...

Je me demande si c'est possible de tricher, peut-être que ça marcherai! J'entends par la prendre un programme qui enregistre une image de la webcam toute les 0.25 secondes par exemple, et utiliser un autre programme qui simule une webcam en prenant l'image comme référence... Ça pourrait marcher ?

Parce que là j'ai toujours une images verte coupé en deux avec des superpositions.... (c'est pas le probleme, que j avais aussi avant ou tout est vert sans bouger)

merci de t es réponse, j espère trouver une solution à se problème très genant! Ma copine aimerai bien me voir...

A plus
0
Salut a tous,

J'ai trouver la solution à mon problème :-D

Mon problème était que ma caméra avait une résolution de 640x480 et que ce n'est pas réglé comme ça de base dans skype! D'ou très logiquement mon problème de "superposition"

Il vous faut aller dans le fichier /home/<user name>/.Skype/<Skype user name>/config.xml

et ajouter les lignes:

<Video>
<CaptureHeight>480</CaptureHeight>
<CaptureWidth>640</CaptureWidth>
<RecvPolicy>callpolicy</RecvPolicy>
</Video>

Et magie... Ca marche!!!

Bonne fin de journée à tous :-D
0
mamiemando
Messages postés
31212
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 juillet 2022
7 370 > Inceptor
6 nov. 2009 à 01:00
Merci pour ces précisions !

Bonne continuation sous linux ;-)
0
christian.zennaro
Messages postés
50
Date d'inscription
lundi 8 décembre 2008
Statut
Membre
Dernière intervention
20 octobre 2012
1
25 févr. 2010 à 11:57
Salut a tous.
Mais où allez vous cherchez tout ça, ha ha ha !!!!
Je viens de mettre Ubuntu sur mon lap top et bien sur la web cam ne fonctionne pas avec skype, j'ai tenté de suivre vos solutions et , et , ben c'est du chinois pour moi.
Y aurait_il quelqu'un de patient pour m'expliquer tout cela, ou trouver par exemple l'endroit ou modifier skype ???
Bonne soirée
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mamiemando
Messages postés
31212
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
6 juillet 2022
7 370
25 févr. 2010 à 12:01
Hello Christian,

Merci d'ouvrir un nouveau fil de discussion sur le forum linux, éventuellement en faisant référence à celui-ci.

Afin que l'on puisse t'aider il sera important d'y préciser ton modèle de webcam, ta version d'ubuntu etc...

Décris-y précisément les symptômes (webcam pas du tout reconnue, image parasitée etc...) car ce n'est pas forcément le même problème.

Bonne continuation
0
Bonjour,
J'ai un probleme avec le skype 2.1 beta sur Ubuntu Karmic.
Ma video est reconnue dans skype (aspire one je precise) et marche impec quand je fais un test dans les options.
Quand je veux par contre faire un call, aucun succes, il n'y a aucune option qui apparait pour montrer la webcam. Et si je mets "afficher tt la webcam" dans les options, rien n'y fait, mon correspondant ne voit rien.

Je precise que la webcam marchait bien sous la precendete version de Skype 2.0.

Si vous avez une idee comment resoudre ce probleme, je suis preneur...

merci
0