Excel 2003 : Afficher une valeur identique

[Résolu/Fermé]
Signaler
-
 Angy -
Bonjour,

J'ai créé un fichier excel assez simple pour suivre la gestion d'un projet.

J'ai une liste de "To Do" regroupé par catégorie. Devant chaque action, j'inscrit "OK" ou "TD". J'aimerais trouver une formule qui me permettrait d'analyser toutes les lignes d'une catégorie et m'inscrire "OK" si toutes les lignes dans la 2e colonne ont la même valeur soit "OK" ou "vide", sinon inscrire "TD".

Voici un exemple concret :

COLONNE A COLONNE B
A4 - RÉDACTION / MISE À JOUR (catégorie)
A5 Promotions mensuelles OK
A6 Article Blog TD
A7 Nouvelles sections TD
A8 Communiqué de presse OK
A9 PPC

J'ai essayé cette formule : B4 =NB.SI(B5:B9;"OK"), mais cela me donne que le total des "OK", j'aimerais être en mesure de voir en un coup d'oeil le statut de toutes mes catégories avec des "OK" ou "TD".

J'espère que ma demande est claire. Merci de votre aide !

4 réponses

Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Bonjour

J'espère que ma demande est claire. Merci de votre aide !

euhhhh....! pourquoi ce qui marche avec "OK" ne peut il pas marcher avec TD

tout ce que je peux vous proposer _au hasard_ est une formule qui compte le nombre de lignes avec du texte en A et la compare au OK en B
soit:
=SI(NB.SI(A4:A1000;"<>")=NB.SI(B4:B1000;"OK"));"OK";"TD")
ceci, bien entendu pour un champ qui va de 4 à 1000, la cellule ou vous placez cette formule vous renverra TD tant que la colonne B ne sera pas remplie de OK et <OK sinon
si vous voulez aussi inclure les cellules vides de B comme équivalentes à OK, placez la formule plus simple:
=SI(NB.SI(B1:B100;"TD")>0;"TD";"OK")
mais ça , c'est seulement si on s'est compris?
Crdlmnt


Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 897
Bonsoir,

En fait il ne te faut aucun TD donc :
=si(NB.SI(B5:B9;"TD")>0;"TD";"OK")

eric
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Salut Eriiic et merci pour ton info... un peu de carabinier :-)
Mais c'est toujours un plaisir de croiser les amis.
Bien amicalement
Messages postés
24184
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 897
Ah ben je ne t'avais pas vu...
Salut à toi :-)
Quelle info de carabinier ?
(d'ailleurs c'est quoi ce qualificatif ? pas utilisé dans mon pays ça ...)
eric
Merci beaucoup Vaucluse et Eriiic.. Ca marcheeeeeeee :o)