Moyenne avec condition. 2 colonnes

Fermé
Signaler
-
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
-
Bonjour,
Voilà une formule que je n'arrive évidemment pas à trouver me simplifierai énormément la vie. voici mon problème

J'ai une colonne X avec des noms. Une autre Y avec les jours.
Je veux qu'il me fasse la moyenne des jours de stockage pour mes fabriquants. Je veux que quand par exemple j'ai MNRTI dans la colonne X il additionne les jours de la colonne Y correspondant et les divise par le nombre de produits de ce fabriquant (nombre de produit, cette cellule est déjà créée).

Est-ce possible? merci de votre aide.

4 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 560
bonjour

Tu devrais y parvenir avec cette formule :

=SOMMEPROD(($X$1:$X$300=X1)*($Y$1:$Y$300))/SOMMEPROD(($X$1:$X$300=X1)*1)
Messages postés
12257
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
3 septembre 2021
2 666
Bonjour,
Ta solution passe par la formule SOMMEPROD associée à NB.SI.
Supposons que :
- tes noms sont écrits de A1 à A20
- les jours correspondants de B1 à B20
En C1 tu inscrit le nom dont tu cherches la moyenne et en D1 :
=SOMMEPROD((A1:A20=C1)*(B1:B20))/NB.SI(A1:A20;C1)
Explications :
SOMMEPROD((A1:A20=C1)*(B1:B20)) te donne le total de jours correspondant au nom inscrit en C1
NB.SI(A1:A20;C1) le nombre de fois ou dans (A1:A20) on trouve le nom inscrit en C1
Et voili voilou
merci pour votre temps mais cela ne fontionne pas.

Je tiens à préciser qu'un même nom peut être présent plusieurs fois dans la colonne des "A"

Voici ce que la formule devrait donner:

=SOMMEPROD((K38:K1834=MB)*(W38:W1100))/NB.SI(K38:K1845;K38)

Mais une erreur "#NOM?" apparait.

Encore merci
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 560
bonjour

une erreur "#NOM?" apparait : normal MB est certes une marque connue mais pas pour excel et tu ferais mieux de le remplacer :
- par son adresse cellule K38
- ou par le libellé "MB" mais dans ce cas il faut remplacer aussi K38 par ce libellé.

L'encodage des fonctions est très précis et ne supporte pas l'à-peu-près.