Excel, Somme avec double condition de validat

[Résolu/Fermé]
Signaler
-
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
-
Bonjour,

Je cherche a mettre en place une formule me permettant de récupérer le nombre de ligne correspondant à deux critères: le premier est une validation par comparaison et le second est sur une plage de temps.

Ex:

Tableau de données:

Action: date de réalisation:
A 12/02/09
B 26/05/09
C 16/06/09
B 02/08/09
C 06/09/09
C 25/11/09
A 12/12/09


Plage: du: 01/01/09 au: 25/08/09

Action: Nb réalisées
A 1
B 2
C 1


la formule comptabiliser le nombre d'action: ( =NB.SI(colone de la donnée;donnée) )
j'ai tenté de trouver la solution à mon problème mais sans résultat :/

Si quelqu'un a une solution je suis prenneur :)

Merci d'avance

7 réponses

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Bonjour
un exemple de solution:
De A1 à A100, les codes
De B1 à B100, les dates
en C1 date maxi
en C2 date mini
en C3 code cherché
En C4, la formule:
=SOMMEPROD((A1:A100=C3)*(B21:B100<=C1))-SOMMEPROD((A1:A100=C3)*(B1:B100<=C2))
Nota
cette formule inclus la date maxi et exclus la date mini.Pour modifier:
exclure une date limite:supprimer le égal associé au <
(il faut inclure la date mini pour l'exclure du calcul)

Crdlmnt

2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Merci pour la formule, je suis en train de tenter de l'adapter (Excel n'arrive pas à me sortir les sommes) et cela donne:

=SOMMEPROD((NB.SI('Actions CO 2009'!B:B;'Objectifs et Indicateurs'!A8))*('Actions CO 2009'!J:J<='Objectifs et Indicateurs'!C3))-SOMMEPROD((NB.SI('Actions CO 2009'!B:B;'Objectifs et Indicateurs'!A8))*('Actions CO 2009'!J:J<='Objectifs et Indicateurs'!C2))

Je suis bloqué sur la partie en gras, pas moyen de récupérer une donnée format date pour la comparaison :/

si l'un de vous a la solution :)

je continue de chercher de mon coté
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
774
Voila dans un premier temps, avec une étape intérmédiaire :

http://www.cijoint.fr/cjlink.php?file=cj200910/cijruqdbHh.xls
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Re
1°)vous avez placé des NB.SI dans la formule SOMMEPROD on ne voit pas très bien pourquoi

2°) la formule SOMMEPROD n'accepte pas les limites de champ avec les N° de colonne seulement, il lui faut aussi les N° de lignes, identiques dans les deux items de chaque partie.

Ainsi ce que vous cherchez devrait s'écrire:
=SOMMEPROD(('Actions CO 2009'!B1:B1000;'Objectifs et Indicateurs'!A8))*('Actions CO 2009'!J1:J1000<='Objectifs et Indicateurs'!C3))-SOMMEPROD(('Actions CO 2009'!B1:B1000;'Objectifs et Indicateurs'!A8))*('Actions CO 2009'!J1:J1000<='Objectifs et Indicateurs'!C2))

ceci bien entendu si votre champ de recherche ne va pas plus loin que 1000

Par ailleurs, vous auriez interêt avec des noms de feuille aussi complexes à nommer vos champs et vos cellules.

Sélectionnez un des champs et:
Barre d'outil /Insertion / Nom /Définir (sur excel 2003_sur 2007, même principe mais chemin diffèrent)
fenêtre du haut rentrez un nom simple.
Sur la formule ci dessus ça pourrait donner:
Nommer:
'Actions CO 2009'!B1:B1000: CODE
'Actions CO 2009'!J1:J1000 : DATE
et si vos cellules résultat sont sur une 3° feuille
'Objectifs et Indicateurs'!A8 : RECH
'Objectifs et Indicateurs'!C3 : DTMAX
'Objectifs et Indicateurs'!C2 : DTMIN
votre formule devient:
=SOMMEPROD((CODE=RECH)*(DATE<=DTMAX))-SOMMEPROD((CODE=RECH)*(DATE<=DTMIN))
ça fait plus clair là, non?
Bien cordialement
énorme merci pour votre aide :)

ca fonctionne du tonerre :)
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
774
bonjour,

pur ma part, je n'ai pas bien compris ce que tu voulais faire.
Peut être peux tu joindre un exemple de fichier (avec les données d'entrées et surtout le type de résultat souhaité) ?
Salut dobo69:

Effectivement je ne suis pas très clair et je m'en excuse

Mes données d'entrées sont sous forme de tableau (pour simplifier mon exemple j'ai mis uniquement les deux colones qui m'intéressait):
colone 1 colone 2
Action: date de réalisation:
A1 A 12/02/09
A2 B 26/05/09
A3 C 16/06/09
.. B 02/08/09
.. C 06/09/09
.. C 25/11/09
.. A 12/12/09
.. ... ......



Le résultat que j'aimerais extraire de ce tableau de donnée est le suivant:

Plage de temps:
du: XX/XX/XX (Ex: 01/01/09) au: XX/XX/XX (Ex: 25/08/09 )

Action Nb réalisées
A X( 1 pour l'exemple)
B X( 2 pour l'exemple)
C X( 1pour l'exemple)


J'espere que cette présentation est mieux compréhensible :)

Cordialement
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
774
dans ton tableau tu parles de 2 colonnes mais il y a 3 données par lignes (A1 A 12/02/09 par exemple). Comment ca marche ? A et 12/02/09 sont dans la même cellule ?

Tu peux joindre un fichier exemple ici . Copier/coller le lien dans ta réponse.
Merci :)

Voila:

http://www.cijoint.fr/cjlink.php?file=cj200910/cijZXwlx6s.xls
Messages postés
1584
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
30 juin 2013
774
y a pas à dire : excellent..
"où vaucluse passe quidam moyen trépasse"
merci pour la solution que tu propose :)

je la tenterais si l'on ne trouve pas la possibilité de le faire en une formule.
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 091
Pas de quoi, j'en suis ravi
Bonne route!
crdlmnt