Excel: comment comparer 2 fichiers (ss ordre) [Résolu/Fermé]

Signaler
-
Messages postés
17414
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
28 juillet 2021
-
Bonjour tous le monde,

J'ai deux (gros) fichiers Excel avec dedans les même numéros de points... j'ai traité et modifié le premier fichier et je souhaite maintenant vérifier que je n'ai perdu aucunes informations durant ce processus.
Je sais déjà comment comparer deux colonnes mais le soucis c'est que c'est comparaison tient compte de l'ordre des numéros de points.
Donc en fait je voudrais savoir comment vérifier que tous le numéros du deuxième fichier se retrouve bien dans le premier sans tenir compte de l'ordre (j'ai pas trié mes données de la même façon).
Et une fois ça fait, est-ce que quelqu'un connaitrait un moyen de trier le 2eme fichier comme le 1er sans recommencer tout mon processus de tri.

Merci d'avance à tous.

6 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 475
bonjour

Tu n'as pas besoin de trier ton classeur pour vérifier la présence.

Tu donnes un nom à ta colonne numéros du premier fichier : "numeros" par exemple.

Après avoir sélectionné la colonne "des numéros du deuxième fichier", tu fais le menu format / mise en forme conditionnelle

Tu choisis la formule =ESTERREUR(EQUIV($A1;numeros;0))
en remplaçant A par ta colonne sélectionnée, et tu mets le format.

Les numéros absents du premier fichier seront colorés.
Messages postés
15
Date d'inscription
mercredi 7 octobre 2009
Statut
Membre
Dernière intervention
7 janvier 2010
2
Merci gbinforme,

j'ai compris comment fonctionnent les 2 fonctions...

tu en aurais pas d'autres pour me permettre de classer mes "colonnes" dans le même ordre, je m'explique:
mettons que j'ai :

colonne 1 colonne 2
d a
b b
a c
c d

Est ce qu'il existe une manip' pour que la colonne 2 soit trier dans le meme ordre que la colonne 1 ?

MERCI
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 475
bonjour

Je veux bien te donner la formule que tu voudrais mais encore faudrait-il que je comprenne ton questionnement car si je change ton exemple ainsi :

colonne 1 colonne 2
Durand anatole (d a)
Babar bernard (b b )
anonyme christian(a c )
Camard david (c d)

Tu comprends bien que si la colonne 2 est triée dans le même ordre que la colonne 1 tous les noms vont changer de prénom et en général ce n'est pas ce que l'on recherche dans une base.
Messages postés
15
Date d'inscription
mercredi 7 octobre 2009
Statut
Membre
Dernière intervention
7 janvier 2010
2
Il n'y a pas de souci... car les lettres de mon exemple sont les même dans les deux colonnes... ce ne sont pas des prénoms ou des noms... juste des numéro de point et pour le coup je veux juste les trier pareil... je n'ai pas fait subir le processus de tri et de traitement à mes 2 colonnes... et donc plutôt que de devoir recommencer tout depuis le début je voudrais que la 2eme colonnes soit dans le même ordre que la 1ere.

Merci d'avance
Messages postés
15
Date d'inscription
mercredi 7 octobre 2009
Statut
Membre
Dernière intervention
7 janvier 2010
2
Bon ben c'est pas grave, je vais me débrouillé autrement...
ça sera plus long c'est tout :p
Messages postés
17414
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
28 juillet 2021
4 669
Salut,

Tu as un outil formidable Excel, si tu donnais plus d'explications ou mieux un exemple de fichier, il serait plus facile pour nous de comprendre tes attentes.
Ton fichier tu peux le mettre sur un post avec ce lien

https://www.cjoint.com/

En attendant, en supposant que tu souhaites comparer la colonne A du fichier1 à la colonne A du fichier2 quelque soit l’ordre de saisie des données dans les deux fichiers

Première formule, marquera #N/A si une valeur est absente

=SI(EQUIV(A:A;'[Formule Doublons.xls]Feuil3'!$A:$A;0)=LIGNE();"absent";"ok")

La deuxième formule plus évoluée

=SI(ESTERREUR(SI(EQUIV(A:A;'[Fichier2.xls]Feuil3'!$A:$A;0)=LIGNE();;));"Absent";SI(EQUIV(A:A;'[Fichier2.xls]Feuil3'!$A:$A;0)=LIGNE();"Absent";"ok"))

Parfois les formules complexes sont polluées en passant par le forum si c’était le cas je te la mettrais sur un fichier


A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)