Excel 2007 : trop d'arguments dans la formule

[Résolu/Fermé]
Signaler
-
 vulkey -
Bonjour,

J'ai un problème avec excel qui me dit qu'il y a trop d'arguments dans ma fomule :

=SI(esterreur(CHERCHE($A2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($c2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($e2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($g2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($i2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($k2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($m2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($o2;Bx$2));$Bb$2;$Bd$2)+SI(esterreur(CHERCHE($q2;Bx$2));$Bb$2;$Bd$2)

Cette formule me permet de renvoyer le nombre de cellules (9 au total) dont le contenu est identique à la valeur de bx$2 (avec bb$2=0 et bd$2=1).

Quel est la solution ?

Merci par avance.

3 réponses

Messages postés
54894
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
16 799
Bizarre :
J'ai recopié ta formule : aucun message, tout baigne !

Vérifie qu'il n'y a pas une erreur de saisie : une parenthèse, un point-virgule ...
Parce que ta formule est correcte.
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
6 092
Bonjour

je viens comme Raymond de rentrer la formule et effectivement elle semble correcte, au moins acceptée mais quelque chose me chagrine par rapport à ce que vous avez expliqué:
si vous voulez détecter les cellules qui contienne la valeur de BX2 en A2,C2, etc... il faut, si je ne me trompe pas, écrire l'inverse, à savoir pour que "cherche BX2 dans A2" fonctionne:
=SI(ESTERREUR(CHERCHE(BX2;A2));BB2;BD2)
Soit en premier la valeur cherchée et en second la plage de recherche
Après test exemple,(ci joint) tout fonctionne normalement
http://www.cijoint.fr/cjlink.php?file=cj200910/cijX898vjK.xls
Crdlmnt
Bonjour,

Comme j'ai beaucoup travaillé encore après avoir envoyé le message, j'ai cherché une autre alternative.

Pouvez vous me confirmer que je comprend cette ligne correctement ?

Note : je compare des cellules ne contenant qu'une UNIQUE lettre.

=SI(ESTNUM(TROUVE(H2;$CW$2));$CW$1;SI(ESTNUM(TROUVE(H2;$CY$2));$CY$1;SI(ESTNUM(TROUVE(H2;$DA$2));$DA$1;SI(ESTNUM(TROUVE(H2;$DC$2));$DC$1;$BU$2))))

Si h2 est $cw$2 (c) écrire $cw$1 (14) sinon si h2 est $cy$2 (k) écrire $cy$2 (15) sinon si h2 est $da$2 (p) écrire $da$1 (16) sinon si h2 est $dc$2 (t) écrire $dc$1 (17) sinon écrire $bu$2 (0).

Je demande ca parce que quand h2 est (c), (k), (p), (t) ca écrit bien (14), (15), (16), (17) mais quand la cellule est vide ca écrit (14) au lieu de (0).

Merci par avance.
Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2021
6 092
Bonsoir
"Note : je compare des cellules ne contenant qu'une UNIQUE lettre"
je ne comprend pas ce que vous voulez faire.
S'il n'y a qu'une seule lettre dans les cellules à comparer, pourquoi ne pas faire directement:
=SI(H2=$CW$2;etc.....
je ne vois pas l'utilité de passer par trouve, qui va compter la position d'une lettre dans un texte complet?
Crdlmnt
Bonjour,

Parfait ca marche, j'avais un doute quand a la fonctionnalité avec les lettres.

Merci.