Problème excel

Résolu/Fermé
alzec002 - 10 sept. 2009 à 19:41
 alzec002 - 10 sept. 2009 à 20:34
Bonjour à tous,

bon je suis peut-être un peu parano mais bon, voila mon problème :

j'essaye de mettre automatiquement les points des matches de ligue des champions ou autres matchs de foot, dans un tableau préparer. Je fais des formules pour les victoires , les nuls et les défaites seulement pour les matchs nuls j'ai un problème : je rentre les scores de matchs comme ceci.

Barcelone - Marseille : 1-1 par exemple, je mets donc pour avoir "1" que SI la différence entre les buts de la première équipe par rapport à ceux de la deuxième est égal à zéro j'obtiens 1 dans une autre colonne. Seulement, même si aucun chiffre n'est rentré, il me calcule quand même la valeur, or je veux calculer une valeur seulement quand ya un chiffre dedans. voici la formule que j'utilise : =SI(N5+(-O5)=0;1;0)
et j'aurais voulu savoir si il y a une formule pour faire ce calcul seulement quant un chiffre est entré dans la colonne précédente.
A voir également:

8 réponses

J'ai oublié le merci ;)
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
10 sept. 2009 à 19:57
Bonsoir
Essayez:
=SI(ET(N5=0;O5=0);0;SI(N5=O5;1;0))
Vous pouvez bien sur continuer avec
=SI(ET(N5=0;O5=0);0;SI(N5=O5;1;SI(N5>O5;X;SI(O5>N5;Y;0))))
X et Y étant les valeurs que vous voulez affecter dans les condition stipulées
Crdlmnt
Hum ça fonctionne correctement sauf pour 0-0 :s

Merci quand même
Sinon c'est rien je peux laisser comme ça et changer moi même si c'est 0-0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Ou alors il faudra imbriquer des OU et des ET :
on a 1 quand [(N3=0 ET O3=0) ou (N3=1 ET O3=1) ou (N3=2 ET O3=2) etc]

Mais je ne sais pas comment imbriquer les OU avec les ET
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
10 sept. 2009 à 20:26
Re alors essayez ceci
=SI(ET(ESTVIDE(N5);ESTVIDE(O5));"";SI(N5=O5;1;0))
La cellule sera doc vide quand N et O seront vides et compterons un match nul lorsque N et O seront égales à 0

A défaut, dites nous ce que vous voulez obtenir quand le match est nul!

Bonne soirée
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 407
10 sept. 2009 à 20:28
Add. au message précédent:
vous pouvez remplacer le ET par OU si vous voulez une cellule résultat vide lorsqu'une des deux cellules N ou O est vide
Non avec le ET cela fonctionne très bien :)
Je veux avoir un 1 quand jai un chiffre dans les deux cases et quand les deux chiffres sont égaux. ^^
Je vous remercie beaucoup, ça fais quelques jours que je réfléchi la dessus sans succès ;)

Bonne soirée