Transformation cellule negative Excel [Résolu/Fermé]

Signaler
-
 fabj57 -
Bonjour,
j'ai un souci : je souhaiterais avoir une formule pour transformer le contenu d'une cellule Excel afin d'obtenir
les nombres negatifs
exemple :
contenu de la celluleA1 : 4,129.78- resultat souhaité : - 4,129.78
contenu de la celluleA2 : 405.55- resultat souhaité : - 405.55
contenu de la celluleA3 : 5.49 resultat souhaité (pas de changements): 5.49

Merci d'avance pour votre aide et bonne journée.

3 réponses

Messages postés
16390
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2021
3 141
curieux, ca fonctionnait chez moi...

je viens d'essayer çà qui fonctionne aussi:
=SI(DROITE(B7;1)<>"-";B7;GAUCHE(B7;NBCAR(B7)-1)*(-1))
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Merci Michel,
cela fonctionne .
bonne journée.
Messages postés
4347
Date d'inscription
samedi 15 mars 2008
Statut
Contributeur
Dernière intervention
2 novembre 2013
1 339
Salut,

pour faire ceci tu sélectionnes tes cellules, clique a droite format de cellule, su sélectionnes Nombre , 2 décimales, tu coches "utiliser le séparateur de milliers", et dans l'encadré Nombres négatifs tu prends -1 234.00

Voilà :)

maintenant si tu écris 5.49 il va donner 5.49
-5.59 va donner -5.49
-1223.25 va donner -1 223.25

voilà
Messages postés
16390
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2021
3 141
bonjour
=SI(DROITE(B3;1)<>"-";B3;-GAUCHE(B3;NBCAR(B3)-1))

à traduire en anglais...
Merci Michel
apres tests il semblerait que le - avant gauche ne soit pas apprecié par Excel (message #VALEUR!)
en le supprimant il recopie bien le contenu de la cellule en commencant par la gauche
=SI(DROITE(B7;1)<>"-";B7;GAUCHE(B7;NBCAR(B7)-1))

si l'on peut multiplier le resultat par -1 cela devrait fonctionner, mais comment faire..

Merci d'avance pour votre support.