Résolution supperieur en mode text (ubuntu) [Résolu/Fermé]

Signaler
Messages postés
242
Date d'inscription
lundi 19 juillet 2004
Statut
Membre
Dernière intervention
6 novembre 2008
-
 avrelus -
Bonjour,

J'utilise depuis un moment la ubuntu (sans problemes), je voudrai juste avoir une meilleur résolution en mode text (boot et Ctrl-Alt-Fn), comme la knoppix par exemple.

Y a t'il une option a modifier dans Grub ? le noyau a reconfigurer ? une simple config ?

Merci

3 réponses

Messages postés
1185
Date d'inscription
dimanche 20 mars 2005
Statut
Membre
Dernière intervention
5 janvier 2006
5
il faut charger le framebuffer correspondant à ta carte.

Soit tu démarres sans framebuffer (video=vga16:off) puis tu charges le module (pour autant qu'il soit disponible), soit tu recompiles ton noyau en l'incluant.

ensuite, un coup de fbset te permet de charger le mode approprié

personnellement je ne suis toujours qu'en console (et très rarement -mettons 5% du temps- sous X) et la console en 1024 c'est un vrai bonheur (ou au dessus si ta carte le permet)

consulte le Framebuffer-HOWTO, il doit être dans ta documentation incluse, sinon tu l'as ici en français:

http://perso.wanadoo.fr/m.malenki/doc/howto/fr/Framebuffer-HOWTO/Framebuffer-HOWTO.html
Messages postés
242
Date d'inscription
lundi 19 juillet 2004
Statut
Membre
Dernière intervention
6 novembre 2008
6
Merci pour le tuyau, je vais regarder ça et je te tiens au courrant.
Messages postés
242
Date d'inscription
lundi 19 juillet 2004
Statut
Membre
Dernière intervention
6 novembre 2008
6
C'est déja beaucoup mieux !

En fait j'ai une très récente version de Linux et vesafb était déje chargé au démarrage, il m'a juste suffit de fournir au noyau lors du boot l'option vga=795. Je suis donc maintenant en 1280x1024.
(Quel bonheur !!) Seulement (je chipote un peu) je suis en 1680x1050 sur portable et donc certains caracteres sont un peu flous (une ligne sur deux)
J'ai vu qu'avec la commande fbset on pouvait modifier plus finement les parametres mais quelque soit la commande que je tape, rien ne change (pas de message d'erreur non plus). Faut-il rebooter ?

Mais bon comme je dis, je chipote, c'est déja très bien.

Encore merci
Messages postés
1185
Date d'inscription
dimanche 20 mars 2005
Statut
Membre
Dernière intervention
5 janvier 2006
5
vesafb se tamponne de fbset

charge le framebuffer correspondant à ta carte graphique, soit en le compilant dans le noyau, soit en le compilant en module puis modprobe au démarrage (il se peut aussi qu'il soit déjà disponible)
ça peut peut-être vous aider :

http://www.dejadejoder.com/spip/spip.php?article14