Windev Tableau 2 dimensions [Résolu/Fermé]

Signaler
Messages postés
80
Date d'inscription
mardi 10 juin 2008
Statut
Membre
Dernière intervention
7 février 2010
-
Messages postés
80
Date d'inscription
mardi 10 juin 2008
Statut
Membre
Dernière intervention
7 février 2010
-
Bonjour,
Je souhaite faire un tableau à deux colonnes suivant une condition de sélection d'une table.
J'ai regardé l'aide windev et différents forum mais je ne trouve pas grand chose qui permet de m'aider.
Je sais qu'il faut déclarer un tableau dynamique et lui allouer le nombre d'élément que l'on veut, mais après je ne sais pas comment on fait pour insérer les informations dans le tableau.
J'ai fait ça mais ça marche pas du tout :(
TblFamille est un tableau dynamique
TblFamille = allouer un tableau dynamique de 1 par 1 chaîne
i est un entier = 1
POUR TOUTE LIGNE DE Table
SI Col_Selection..Valeur=1 ALORS
TblFamille[1][i]=Table.CodeFamille
TblFamille[2][i]=Table.IDARTICLE
i++
FIN
FIN
Pouvez vous m'aider svp?
Merci

1 réponse

Messages postés
80
Date d'inscription
mardi 10 juin 2008
Statut
Membre
Dernière intervention
7 février 2010
16
C'est bon j'ai trouvé pour ceux qui galère voilà la solution :
TblFamille est un tableau dynamique
TblFamille = allouer un tableau dynamique de 1 par 1 chaîne
Nbrselect est un entier
i est un entier = 1

POUR TOUTE LIGNE DE Table
SI Col_Selection..Valeur=1 ALORS
Nbrselect++
Dimension(TblFamille,2,Nbrselect)
TblFamille[1][Nbrselect]=Table.CodeFamille
TblFamille[2][Nbrselect]=Table.IDARTICLE
FIN
FIN
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86556 internautes nous ont dit merci ce mois-ci