Recherche de valeur entre fichier Excel [Résolu/Fermé]

Signaler
-
 Bershax -
Bonjour,

J'aurais grand besoin d'un coup de pouce. Je vous explique ce que je cherche a faire.

J'ai deux fichiers Excel.
Dans le premier j'ai une colonne pour laquelle je souhaite rechercher chaque valeur dans une colonne du second fichier et renvoyer la valeur d'une seconde colonne du second fichier dans une seconde colonne du premier fichier.

Pour etre plus clair
J'ai un fichier "Fa" dont je souhaite parcourir la colonne "Ca1" et trouver les correspondances dans le fichier "Fb" colonne "Cb1".
Pour chaque correspondance je souhaite copier la valeur d'une autre colonne du fichier b, "Cb2" dans une colonne du fichier "Fa", "Ca2".

J'ose imaginer qu'un VLookup serait necessaire mais je ne sais pas comment mettre ca en oeuvre.
Si une ame charitable veut bien me venir en aide.

Par avance merci.

6 réponses

Ca marche parfaitement.
Merci beaucoup Raymond!!
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 283
Bonjour,
A insérer dans B2
=SI(A2="";"";RECHERCHEV(A2;Feuil2!A1:B5;2))
le catalogue est sur la feuille2 en colonne A et B
Faire une recopie vers le bas

A+

pépé
Messages postés
52434
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
14 282
Non, pépé ! Ta procédure est valable pour 2 feuilles d'un même fichier.
Breshax travaille sur 2 fichiers distincts.
Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 283
OK
j'avais mal lu le message.

pépé
Messages postés
52434
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
14 282
Bonjour, Breshax .

* 1) Tout d'abord, mettons-nous d'abord sur le vocabulaire :
.......... Tu as un fichier Fa.xls dont tu souhaites parcourir la colonne A et trouver les correspondances dans le fichier Fb.xls, en colonne B, que tu répercutes dans la colonne B du fichier Fa.xls. 272 Est-ce de cela qu'il s'agit ?
* 2) Tu évoques la fonction VLookup ; j'en déduis que tu utilises une version anglaise d'Excel ?
* 3) Si ta liste de données dans Fb.xls occupe la plage A1:B99, tu commences par donner à cette plage le nom "matrice". De retour dans le fichier Fa.xls, tu saisis en cellule B1 la formule =RECHERCHEV(A1;Fb.xls!matrice;2,FAUX) et tu la recopies vers le bas.
Attention : Il faut que le fichier Fb.xls reste ouvert, et que la plage "matrice" ne comporte pas de ligne vide.
Merci pour vos réponses rapides.


J ai un un fichier Fa.xls dont je souhaite parcourir la colonne A et trouver les correspondances dans le fichier Fb.xls en colonne A dans le but de répercuter la colonne B du fichier Fb.xls dans une colonne B du fichier Fa.xls.

Pour exemple :

Fichiers initiaux

Fa.xls

ColA ColB
bleu -
rose -
vert -
bleu -

Fb.xls

ColA ColB
bleu 1
rose 2
vert 3
Fichier finaux

Fa.xls

ColA ColB
bleu 1
rose 2
vert 3
bleu 1

Fb.xls

A B
bleu 1
rose 2
vert 3

Voila j'espere que c'est assez comprehensible.

Merci encore
Messages postés
52434
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
14 282