Recherche dans tableau Excel

Résolu/Fermé
Enito
Messages postés
21
Date d'inscription
jeudi 9 juillet 2009
Statut
Membre
Dernière intervention
22 février 2012
- 9 juil. 2009 à 20:28
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
- 10 juil. 2009 à 16:14
Bonjour,

Je voudrais faire une recherche dans un tableau de 3 lignes par 3 colonnes. J'aimerais savoir dans quelle colonne se trouve la valeur cherchée. La cellule de recherche est A1 et le tableu de B1 à D3. Je n'ai pas réussi avec une recherche verticale car c'est toujours une recherche dans la première colonne.

Merci !

11 réponses

michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
9 juil. 2009 à 20:38
Bonsoir:

=SOMMEPROD((B1:D3=A1)*COLONNE(B1:D3))
te donne le numéro de la colonne de la valeur affectée à A1
0
Enito
Messages postés
21
Date d'inscription
jeudi 9 juillet 2009
Statut
Membre
Dernière intervention
22 février 2012

9 juil. 2009 à 20:47
Bonjour,

Si je nomme mes colonnes, est-ce que ça pourrait me dire si la valeur se trouve dans la colonne bleue, blanche ou rouge ?

Merci
0
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
9 juil. 2009 à 22:12
ta demande était quelle colonne: je t'ai proposé une réponse.
aucun merci
maintenant c'est bleu, blanc, rouge
après c'est quoi comme question?
ciao
0
Enito
Messages postés
21
Date d'inscription
jeudi 9 juillet 2009
Statut
Membre
Dernière intervention
22 février 2012

9 juil. 2009 à 22:37
Bonjour,

Désolé de ne pas avoir dit merci. Ta réponse m'a grandement aidé.

J'avais dit quelle colonne car je pensais m'en sortir avec deux fonctions Si imbriquées pour déterminer si la valeur est dans la colonne Bleu, Blanc ou Rouge. La réponse que tu m'as fourni fonctionne pour les colonnes 2 & 3 mais pas pour la colonne 1. Au lieu de 1, ça indique la colonne 18.

Merci de me répondre à nouveau,

Bonne journée !
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 184
10 juil. 2009 à 02:29
Enito, bonjour.

Au post 4, tu prétends que "La réponse que tu m'as fourni fonctionne pour les colonnes 2 & 3 mais pas pour la colonne 1. Au lieu de 1, ça indique la colonne 18".

J'ai reconstitué ton tableau (tel que décrit initialement), j'ai utilisé la formule de michel_m (post 1), et ça marche au poil : la réponse est soit 2, soit 3, soit 4 ; jamais 18 !
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 184
9 juil. 2009 à 23:13
Tu sais ?
Ce serait beaucoup plus simple, pour comprendre et pour répondre, si tu nous montrais ton fichier.

Cjoint.com ou Cijoint.fr pour créer un lien, que tu colles dans un message.
0
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
9 juil. 2009 à 23:16
C'est bien ... d'encourager ce genre de demandeur,mais ca ne m'étonne pas.
0
Enito
Messages postés
21
Date d'inscription
jeudi 9 juillet 2009
Statut
Membre
Dernière intervention
22 février 2012

9 juil. 2009 à 23:38
Bonjour,

Voici le lien pour le fichier Excel, http://www.cijoint.fr/cjlink.php?file=cj200907/cijtzUgsG4.xlsx

Je souhaiterais imbriquer la formule SommeProd et la fonction SI. Mon objectif ultime est d'écrire une macro permettant de rentrer la valeur dans une nouvelle cellule et que Excel donne la couleur de la colonne juste à côté de la valeur. Je suis correct pour la macro par contre. Par ailleurs, je ne comprends pas pourquoi la formule indique 15 au lieu de 1 lorsque la valeur est 0.

Merci et Bonne journée.
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 184
10 juil. 2009 à 02:58
Enito, bonjour.

Formule en G2 ► dans ta formule
=SI(G2=1;"Bleu";SI(G2=2;"Blanc";"Rouge"))
il te suffit de remplacer G2 par
=SOMMEPROD(($A$2:$C$16=F2)*COLONNE($A$2:$C$16))
ce qui donne (j'ai vérifié, ça marche) :
=SI(SOMMEPROD(($A$2:$C$16=F2)*COLONNE($A$2:$C$16))=1;"Bleu";SI(SOMMEPROD(($A$2:$C$16=F2)*COLONNE($A$2:$C$16))=2;"Blanc";"Rouge"))

Et si tu prends la précaution de donner à la plage A2:C16 le nom Mat, cette formule s'écrit
=SI(SOMMEPROD((Mat=F2)*COLONNE(Mat))=1;"Bleu";SI(SOMMEPROD((Mat=F2)*COLONNE(Mat))=2;"Blanc";"Rouge"))

Quant à si tu parviens à donner le nom CM à la formule =COLONNE(Mat) tu pourras écrire
=SI(SOMMEPROD((Mat=F2)*CM)=1;"Bleu";SI(SOMMEPROD((Mat=F2)*CM)=2;"Blanc";
"Rouge"))

ce qui est beaucoup plus sympa !
0
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
10 juil. 2009 à 08:54
Vive la démago!
en plus c'est NUL: le niveau baisse de + en + sur CCM...
0
Enito
Messages postés
21
Date d'inscription
jeudi 9 juillet 2009
Statut
Membre
Dernière intervention
22 février 2012

10 juil. 2009 à 15:18
Vive les messages constructifs ! Désolé tout le monde ne posséde pas ton niveau de connaissance Michel. Par ailleurs, c'est l'objectif des forums de donner de l'aide à ceux qui ont des questions.

Bonne journée !
0
michel_m
Messages postés
16577
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 août 2022
3 278
10 juil. 2009 à 16:14
JE PERSISTE ET SIGNE, ENITO
quand quelqu'un comme toi ne sait pas dire MERCII quand on l'aide et quie , en plus, il ne présente pas ses excuses quand on lui fait remarquer, si ce n'est un vague "désolé" -le + désolé devant cet état de fait, c'est qui ?-
Et pour couronner le tout, annonce que la proposition ne marche pas sans se donner la peine de vérifier

ALORS OUI, JE PENSE QUE TOUT A CHACUN SUR UN FORUM DOIT ABANDONNER L'AIDE EN COURS.

Et ce, justement, pour garder l'aspect constructif du forum
0