Signe + ou - pourcentage excel (calcul croiss [Résolu/Fermé]

Signaler
Messages postés
47
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
27 septembre 2010
-
 fredoalex -
Bonjour tout l'monde,

J'ai une question un peu bête, mais je suis en train de passer par mille chemins pour la résoudre.

voilà : je veux calculer la croissance sur deux années. Si le résulat est positif, il doit m'afficher le résultat avec un petit "+" avant. le signe moins est ajouté automatiquement en cochant pourcentage dans format cellule.
Je n'arrive pas à afficher le "+"

Pourtant,j'arrive à faire des couleurs en mise en forme conditionnelle (mais ce n'est pas ce que je veux).

en passant par la formule si =SI(C2>0;"+"&C2;C2) , il ne me donne pas des pourcentage quand c'est positif, et aussi on ne peut pas limiter le nombre de décimales.

NB : =(B2-A2)/A2

Serait-il possible de mettre toute la formule dans la même cellule, genre
=SI((B2-A2/A2)%>0;"+"&(B2-A2/A2);(B2-A2/A2))

Hypothèse : A2=100 et B2=50 . il faut aussi tester l'inverse.

merci par avance pour votre aide.

3 réponses


Bonjour,
Une autre solution consiste à appliquer un format --> catégorie --> personnalisée:
[>=0]+ 0,00%;[<0]- 0,00%;Standard
50
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Cette solution est très simple et fonctionne très bien, merci!
Merci super solution
Messages postés
47
Date d'inscription
dimanche 19 avril 2009
Statut
Membre
Dernière intervention
27 septembre 2010
15
merci pour votre réponse,

@Mike-31 : c'est exactement ce que j'avait fait sauf que pour l'exemple (A2 = 150) et (B2 = 400) le résultat est (+ 166,666666666667 %). Impossible de limiter le nombre de décimales)

@tontong : merci c'est exactement ce que je voulais. je savais bien qu'il y avait un moyen très simple de le résoudre et je me tortillais sur des formules tordues.

merci
Messages postés
17242
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
6 octobre 2020
4 283
Salut,

Je ne sais pas si j'ai tout bien compris

testes cette formule

=SI((B2-A2)/A2%>0;"+ "&(B2-A2)/A2%&" %";(B2-A2)/A2%&" %")

Si elle ne répond pas à tes attentes, donne plusieurs exemples, en A2 j'ai ça , en B2 ça le résultat attendu est ça

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)