Formule excel

Résolu/Fermé
DebutanteExcel - 5 juin 2009 à 09:05
 DebutanteExcel - 5 juin 2009 à 09:51
Bonjour,

J’ai besoin d’aide pour une formule excel. J’avais déjà demandé qu’on m’aide et on m’avait expliqué qu’il fallait utiliser la formule ci dessus, cependant, j’ai une chose à ajouter.

=SOMMEPROD((((Z16:Z203="Oui")+(Y16:Y203="Oui"))>0)*(AC16:AC203)*(AD16:AD203))

Dès qu’il y a détection d’un « Oui », dans une colonne ou une autre, alors on multiplie entre elles, deux autres colonnes. Sauf que je souhaiterais que cela se produise, uniquement si dans la colonne AF, il n’y a pas le mot « Aérosol ». C’est à dire, s’il y a le mot aérosol, on ne fait pas sommeprod et s’il y a autre chose que aérosol on fait sommeprod.

Merci de bien vouloir m’aider…

2 réponses

leplot Messages postés 191 Date d'inscription lundi 1 décembre 2008 Statut Membre Dernière intervention 13 août 2015 126
5 juin 2009 à 09:38
Bonjour,

il suffit d'ajouter un test dans la formule
=SOMMEPROD((((Z16:Z203="Oui")+(Y16:Y203="Oui"))>0)*(AC16:AC203)*(AD16:AD203)*(F16:F203<>"Aérosol"))

(je n'ai pas tester mais c'est le principe)
0
DebutanteExcel
5 juin 2009 à 09:51
Merci beaucoup!!!
0