Formules EXCEL nb.si

[Résolu/Fermé]
Signaler
Messages postés
105
Date d'inscription
dimanche 26 avril 2009
Statut
Membre
Dernière intervention
29 décembre 2014
-
 mdp174 -
Bonjour,
quelle formule retenir en excel pour connaître le nombre de la Cellule A1 à A7 et de B1 en B7 de Régional en R, de National en R, de National en N.C ...etc
Merci de m'indiquer si vous connaissez une formule de calcul
La formule =nb.si(A1:A7;"National") +nb.si(B1:B7:"R) donne 4 alors que je cherche la formule me donnant 2 (il y a bien deux lignes en National en R et non 4.

A1 régional B1 R
A2 Aléatoire C
A3 National R
A4 régional N.C
A5 régional C
A6 Aléatoire N.C
A7 National R

3 réponses

Messages postés
17595
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 octobre 2021
4 778
Salut,

Testes cette formule,

=SOMMEPROD((A1:A100="National")*(B1:B100="R"))

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Bonjour,

=SOMMEPROD((A1:A100="National")*(B1:B100="R")) est la bonne formule: malheureusement, j'avais oublié une parenthèse.........

merci à toi....
A plus,

Mdp174,
Crois-tu que ceux qui t'on déjà répondu (à ta question trés mal posée) ne voient pas que tu Bogardises ?
Alors, contrairement à ce que tu as déjà demander dis nous ici combien de colonne différentes il y a dans ton tableau, A1 régional B1 R sont 4 colonnes ou deux...
si tu veux exactement "régional B1 R" il faut le créer ou le mettre " " dans le nb.si(A1:A7;"") comme cela
nb.si(A1:A7;"régional B1 R")
Bonjour,

Deux colonnes
mais ta formule ne correspond pas à mon attente.
J'aai trouvé la formule sous=SOMMEPROD
Mais rassures-toi, je ne bogardise pas........
Simplement mon but était de trouver la bonne formule.....
@ + quant même...........
Messages postés
17595
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 octobre 2021
4 778
Re,

N'oublies pas de mettre ton statut en résolu en haut de ton post ou demade à un modérateur de le faire pour toi en cliquant sur un triangle au dessus du post

Merci
A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
J'ai indiqué sur le forum que le problème est résolu.
merci à toi...
Bonne fin de semaine