Excel: fonction recherche

Résolu/Fermé
Signaler
Messages postés
124
Date d'inscription
vendredi 12 août 2005
Statut
Membre
Dernière intervention
27 mai 2017
-
Messages postés
124
Date d'inscription
vendredi 12 août 2005
Statut
Membre
Dernière intervention
27 mai 2017
-
Bonjour,

comment utiliser la fonction recherche sous Excel ; si je veux que le nom du client s'affiche automatiquement lorsque je tape son numéro

merci

9 réponses


Bonjour,
Il faut par exemple que tu ais deux colonnes la premiére le N° du client, A, la seconde son nom B
et que dans la cellule D1 (à coté de laquelle tu inscrit le N° du client C1) se trouve la formule
si tu as 100 clients
d1=recherchev(C1;$A$1:$B$100;2;faux)
Messages postés
124
Date d'inscription
vendredi 12 août 2005
Statut
Membre
Dernière intervention
27 mai 2017
13
merci bcp ça bien marché ; mais lorsque la cellule C1 est vide ou contient une valeur non disponible D1 contient " #N/A " comment puis modifier cette mention ?

merci
Messages postés
55101
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 023
Salut.

D1 ► =SIERREUR(RECHERCHEV(C1;$A$1:$B$100;2;faux);"")

Bonjour,
Effectivement, la question posée suppose que C1 ne soit pas vide ou si c'est le cas que le résultat en D1 n'est pas d'importance puisque.....pas recherché, nonobstant c'est pas esthétique, alors comme l'écrit Ray, il faut améliorer la formule like this :
=SI(ESTERREUR(RECHERCHEV(C1;A1:B3;2;FAUX)=VRAI);"";RECHERCHEV(C1;A1:B3;2;FAUX))
Messages postés
55101
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 023
Salut, le Canadien !
Pourquoi proposes-tu une formule aussi compliquée ?
La fonction SIERREUR remplace (avantageusement) la combinaison des deux fonctions SI et ESTERREUR, et évite de saisir 2 fois la formule de calcul ; as-tu fait l'essai comparatif ?
Ou pa dakô ?
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
891
Salut le forum

Pour défendre l'autre Canadien,

Une nouvelle fonction d'Excel SIERREUR, ne fonctionne que sous Excel 2007

Mytå (Québec)
Messages postés
55101
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
6 décembre 2021
17 023
Oui, Mytå.

Tu as parfaitement raison.
Mais quand ceux qui posent des questions oublient de préciser s'ils travaillent sur Mac ou sur PC, avec Microsoft ou Open Office, sous Excel 95, 2000, 2003 ou 2007, on peut se tromper ... Et si on vient de proposer des solutions dans la version 2007, eh bien on continue sur sa lancée !
Et quant à hasna84 , qui utilise le site CCM depuis près de 4 ans, elle devrait le savoir ...
Mais rassure-toi, cocotehier et moi, on se connaît, maintenant : Il ne va pas s'offusquer de mon intervention intempestive et hors-propos !
Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
186
pour ne pâs obtenir le #N/A en cas ou la cellule:

=SI(C1=" ";" ";RECHERCHEV(C1;la-table -de- la -matrice;n°-de-colonne;faux))
at ce qui concerne la fonction SIERREUR() qunad vous tapez la fonction va apparaitre un ractangle qui contion la définition de ceete fonction

Bonjour,
Aucun soucis aucun Ray, Mytå, jamais. Je suis en excel 2000 ici et 2003 autre part, 2007 j'ai à peine testé 3h00, par contre du coup c'est moi qui vient d'apprendre encore un truc la. Le bonjour à la Belle Province.
Messages postés
124
Date d'inscription
vendredi 12 août 2005
Statut
Membre
Dernière intervention
27 mai 2017
13
merci pour tout le monde