Problème de connexion Ethernet sous Ubuntu [Résolu/Fermé]

Signaler
-
Messages postés
6
Date d'inscription
mercredi 13 mai 2009
Statut
Membre
Dernière intervention
14 février 2011
-
Bonjour,

je viens d'installer Ubuntu 8.10 intrepid ibex sur un portalbe Dell XPS M1530.
Je rencontre quelques problèmes notamment au niveau de la connexion à internet.
D'après ce que j'ai pu lire, avec une box en DHCP (ce qui semble être mon cas),
la connexion en Ethernet se fait toute seule : Ubuntu récupère directement une
configuration IP partir du serveur DHCP. Dans mon cas, cela ne fonctionne pas du tout.
L'icone de connexion reste inactive, un test ping s'avère un échec. Par contre, quand
j'utilise le gestionnaire de réseau et que je saisis manuellement les paramètres IP, masque réseau...
l'icone m'indique que la connexion est faite mais malheureusement je n'arrive pas à accéder au
web par Firefox. Le test ping est positif à mon adresse IP, négatif pour l'IP de Google, par ex. accompagné
du message 'Network is unreachable'. Quand je vais dans l'Outils réseau, le périphérique réseau qui apparaît
toujours par défaut est le loopback mais même quand je le remplace par l'Interface Ethernet, cela ne fonctionne
pas mieux.
J'aimerais donc avoir l'aide d'âme charitable qui puissent m'aider et répondre par exemple, entre autres,
à ces quelques questions :
Quand la connexion Ethernet ne se fait pas automatiquement en DHCP, faut-il faire la config. manuellement
et si oui comment ? Renseigner la connexion Auto eth0 suffit-il ? Ou faut-il en plus renseigner une connexion filaire dans l'onglet filaire ou ADSL dans l'onglet ADSL ? Quel test effectuer pour identifier les problèmes ?
Dernière précision, j'ai, il y a quelque temps, réussi, en bidouillant au hasard, à me connecter à internet
Ethernet avec le même OS et le même modem (j'ai juste déménagé entre temps). Précision : j'ai un vieil ordi
sous windows XP avec lequel j'arrive à me connecter en ADSL.

C'est sûrement un peu fouilli mais mon inexpérience ne me permet pas de faire plus clair, ni plus
bref. Merci d'avance.

Configuration : Ubuntu 8.10
Modem : Trio 3c
Fournisseur d'accès : neuf

4 réponses

Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
Bonsoir,

C'est assez surprenant que ton DHCP sous Linux ne fonctionne pas, en revanche, je ne suis pas surpris que tu n'arrives pas a surfer si tu prends une adresse IP fixe.
Si tu configure ta cather Ethernet avec une adresse IP fixe, il te faut simplement renseigner les DNS de ton ISP, et la ca marchera.


Maintenant pour ce qui est de ta config en dhcp, tu peux ressayer, et dans un terminal en temps que root, tu lances la commande "dhclient". Tu verras si ta box t'attribue une adresse IP.

Normalement, tu n'as pas besoin d'utiliser l'onglet ADSL, sauf si tu as besoin de saisir un mot de passe dans ton modem pour te connecter a Internet.
Messages postés
6
Date d'inscription
mercredi 13 mai 2009
Statut
Membre
Dernière intervention
14 février 2011

Bonjour,

Merci Synopsis pour ta réponse. J'ai essayé ce que tu m'as dit de faire, sans résultat positif. Je suis également allé sur le forum Ubuntu et ai essayé un pppoeconf, sans plus de succès.
Peut-être, le problème vient-il du navigateur par défaut sur Ubuntu à savoir le Renard de feu. En effet, j'ai un ancien portable sous XP avec lequel j'arrive à me connecter au web par IE (bof bof !) mais pas par Firefox. Par contre, j'ai installé Liberkey (version portable de logiciel libre) et je réussit à me connecter avec la version portable de Firefox.
Double question : comment surfer avec Firefox sur XP et cela peut-il être la cause de mes problèmes avec Ubuntu et si c'est le cas comment configurer Firefox pour que ça marche ?
J'ai en effet fait des ifconfig sur le réseau eth de Ubuntu et des données ont bien l'air d'être transmises : des paquets sont bien reçus.

Merci d'avance.
Messages postés
6
Date d'inscription
mercredi 13 mai 2009
Statut
Membre
Dernière intervention
14 février 2011

NB :

J'ai résolu le problème Firefox sous XP (problème avec le Firewall). Donc, ce que je disais ci-dessus est peut-être inexact (i.e cause problème de connexion sous Ubuntu = problème de navigateur).

Merci pour toute aide. J'aimerais vraiment me lancer sur Ubuntu mais j'ai absolument besoin de pouvoir me connecter sur internet.
Messages postés
1364
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 juin 2013
231
Qu'est-ce que tu utilises pour te connecter ?
Un modem ou une box de type freebox ?
Messages postés
6
Date d'inscription
mercredi 13 mai 2009
Statut
Membre
Dernière intervention
14 février 2011

Bonjour Synopsis,

Merci pour ton aide. J'ai trouvé la solution de mes tourments en appelant le service technique de Neuf pour un problème de connection ADSL. En effet, j'ai eu à déplorer des coupures intempestives de ligne quand j'utilisais mon ancien portable sous XP. J'ai appris presque incidemment de mon correspondant que, pour pouvoir se connecter en ethernet, il fallait désactiver l'option vidéo du modem qui permet de bénéficier de la télé par ADSL (j'ai souscrit à l'offre triple play de Neuf).
Une fois la manipulation faite, il n'y a plus de problème : la connexion internet sur Ubuntu se fait automatiquement.

Bonne continuation à toi Synopsis.