Lien Hypertexte, Fonction SI

Fermé
glister972 - 4 mai 2009 à 16:58
eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 - 4 mai 2009 à 21:15
Bonjour tout le monde ! et Merci déjà à ceux qui pourront m'aider :-D

alors voilà j'ai un fichier excel, dedans plusieurs feuilles. Une feuille pour les commandes et les autres feuilles sont pour les semaines de l'année

donc Feuille 1 : Commande (date darrivée prévue en A1)
Feuille 2 : Sem 01_05
Feuille 3 : Sem 06_09
etc etc....

j'ai une colonne où les liens hypertextes pour chaque feuille sont présents. Cela dépend de la date d'arrivée de la commande.

Ce que j'aurai aimé faire c'est dès que j'écris la date d'arrivée prévue, que le lien hypertexte se mette directement.

J'ai essayé ceci et je sens que je suis proche de la solution :

SI(ET(A1>=01/01;A1<=30/01);LIEN_HYPERTEXTE(Feuil1;sem01_05))

bien sur cela ne fonctionne pas.

Si vous pouviez m'aider ce serait cool.
A voir également:

1 réponse

eriiic Messages postés 24562 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 29 février 2024 7 210
4 mai 2009 à 21:15
Bonsoir,

2 pb dans ta formule : le test des dates et la syntaxe de lien_hypertexte()

Ca devrait être :
=SI(ET(A1>="01/01/2009"*1;A1<="31/01/09"*1);LIEN_HYPERTEXTE(sem01_05!B2;"sem01_05");"")
Et si tes feuilles représentent des mois tu peux mettre plus simplement :
=SI(MOIS(A1)=1;LIEN_HYPERTEXTE(sem01_05!B1;"sem01_05");"")

- Pour tester les dates les mettre en 'chaine' et *1 pour les convertir en numérique.
- pour lien_hypertexte il faut désigner un cellule qui sera active et non seulement la feuille (le plus simple est d'aller cliquer sur cette cellule et la référence se met toute seule dans la formule).
- en plus il manquait quoi faire si le test est négatif si(test;valeur si vrai;valeur si faux) d'où le ;"") à la fin (laisser la cellule vide).

Et n'hésite pas à consulter l'aide excel sur les fonctions, elle est très bien faite.
Lorsque que tu l'écris positionne le curseur dessus, la syntaxe apparait, et si tu cliques sur la fonction dans cette petite fenetre tu chaines sur l'aide.

eric
2