EXCEL-VBA : boucles FOR et IF [Résolu/Fermé]

Signaler
Messages postés
32
Date d'inscription
jeudi 23 avril 2009
Statut
Membre
Dernière intervention
16 mai 2009
-
Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 juin 2021
-
Bonjour,

J'ai un tableau avec plusieurs lignes et 2 colonnes.
A chaque ligne est associée une valeur qui dépendant de la case de gauche, au final, je voudrai connaitre la somme des lignes.

Par exemple,

Colonne 1 Colonne2
rouge ecrire
bleu (vide)
vert sortir

1ère ligne, "ecrire", comme la cellule de gauche = rouge, alors on obient 5
2ème ligne vide, donc 0
3ème ligne "sortir", comme la cellule de gauche =vert, alors on obient 4

et je voudrais avoir en bas de la colonne 2 obtenir (5+4=)9


Connaissez-vous un moyen de résoudre mon problème?

Merci d'avance à tous pour votre aide!

1 réponse

Messages postés
17371
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
11 juin 2021
4 638
Salut,

Tu peux résoudre ce calcul sans VBA avec la fonction NB.SI

Par exemple si ta colonne 2 est colonne B, cette formule comptera le nombre de ecrire et les multipliera par 5 et additionnera de la même façon le sortir

=NB.SI(B1:B25;"ecrire")*5+NB.SI(B1:B25;"sortir")*4

A+