Recherche de cellules non-vides dans colonnes

Fermé
sanchis81 Messages postés 134 Date d'inscription mardi 17 février 2009 Statut Membre Dernière intervention 2 octobre 2013 - 21 avril 2009 à 16:23
Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 - 22 avril 2009 à 12:30
Bonjour à tous,

dans une colonne excel, je retrouve des cases vides et non vides réparties aléatoirement.

J'aimerais pouvoir retranscrire dans une autre colonne excel l'ensemble des valeurs contenues dans les cases non-vides les unes à la suite des autres.

Pourriez-vous m'aider?

D'avance merci
A voir également:

2 réponses

Raymond PENTIER Messages postés 56710 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 5 octobre 2022 17 184
22 avril 2009 à 12:30
Bonjour.
Faire un tri. Récupérer les cellules non-vides : elles sont maintenant contigües.
1
Mike-31 Messages postés 18049 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 30 septembre 2022 4 996
21 avril 2009 à 17:51
Salut,

Tu peux faire simple avec une mise en forme conditionnelle

Mets ta colonne en surbrillance et Format/Mise en forme conditionnelle, sélectionnes la valeur de la cellule est, sélectionnes égale à et saisis =""
Format et sélectionnes une couleur et OK

les cellules vide de ta plage se mettront en couleurs automatiquement.

Il est également possible d'écrire une formule dans une autre colonne

exemple
=SI(A1<>"";"";"vide")
inconvéniant si les cellules contiennent une formule, elles ne sont pas considéré comme vide;

Ou en VBA

A+
0