Excel et fonction "equiv" probleme!

[Résolu/Fermé]
Signaler
Messages postés
8
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
15 avril 2009
-
Messages postés
16499
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 septembre 2021
-
Bonjour,
N'ayant pas trouvé de solution a mon probleme dans le forum je le poste.

J'ai 2 fichier excel, l'un du type:

750054 | 12456 12546 12359 1325
750085 | 231 2546
754130 | 15464
757610 | 57456 74286 14256

et l'autre qui regroupe le premier numero et l'un des numero apres les |.

Ce n'est pas tres facile a expliqué a vrai dire.Cette formule vous parlera peut etre plus...

=INDEX('[Bond site distant ellipse.xls]Feuil1'!$A:$Z,EQUIV(L5,'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0),EQUIV(A5,'[Bond site distant ellipse.xls]Feuil1'!$20:$20,0))

Ma question est: A t'on un moyen de renvoyé la valeur du premier "equiv" (c'est a dire le numero de la ligne ou se trouve le numero (ex: 750085 --> ligne 2 --> 2) afin de pouvoir remplacé automatiquement le "$20:$20" en "$2:$2".
ou un autre moyen pour que le 2e "equiv" se fasse sur la ligne du precedent.
merci d'avance.
Coordiallement.

10 réponses

Messages postés
10330
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
4 septembre 2021
1 184
Bonjour,
Mettre votre exemple sur https://www.cjoint.com/ et poster le lien !
Messages postés
8
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
15 avril 2009

Bonjour, les deux fichier sont disponible ici:

http://cjoint.com/data/eqasIxj7ML.htm
http://cjoint.com/data/eqas3jSOpV.htm

Si vous pouvez m'aider se serai vraiment sympa.
Messages postés
10330
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
4 septembre 2021
1 184
Bonjour,
Difficile de comprendre se que vous cherchez comme résultat.
Toutefois je pense que cette formule devrait vous convenir:
=RECHERCHEV(L1;[ed16091988_ccm_test2.xls]Feuil1!$A$2:$H$30;2;FAUX)
Ou: [ed16091988_ccm_test2.xls] est le nom de votre deuxième classeur
et, le "2" est le numéro de la colonne dont la valeur est renvoyé ...
Messages postés
8
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
15 avril 2009

J'ai bien essayé la formule que vous m'avez donner. Je vous en remercie mais je l'avais deja essayé et cela me renvoie la bonne valeur seulement lorsque je met la bonne ligne: ici 2. Le probleme reste donc le meme que pour ma formule.

La parti de la formule EQUIV(L5,'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0) me renvoie un numero de ligne.
Je souhaite que EQUIV(A5,'[Bond site distant ellipse.xls]Feuil1'!$20:$20,0) me renvoie le numero de colonne.
'[Bond site distant ellipse.xls]Feuil1'!$20:$20 doit donc changer en fonction de la valeur renvoyé par EQUIV(L5,'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0).

J'avais essayé en remplacant '[Bond site distant ellipse.xls]Feuil1'!$20:$20 par '[Bond site distant ellipse.xls]Feuil1'!$1:$100 pour lui donné la plage de donnée a etudié mais il semble que la fonction n'accepte pas.

j'ai aussi essayé en utilisant: =RECHERCHEH(A8,'[Bond site distant ellipse.xls]Feuil1'!$A$3:$L$35,EQUIV(L8,'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0),FAUX)
mais cela ne fonctionne toujours pas. La formule m'affiche #N/A. Cela peut il venir du format des cellules?
Messages postés
16499
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 septembre 2021
3 210
Bonjour à tous

En fait, il faudrait peut-être utiliser la fonction DECALER...
Mais je ne comprend pas la différence avec ta question ( pseudo doudou) sur DVP avec "oui-non"
Messages postés
8
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
15 avril 2009

Sur DVP c'est exactement le meme probleme en faite mais j'ai directement mis la formule finale. Si vous voulez j'ai 2 nombres qui sont par paire par exemple 750154 qui va avec 16744.
Dans le tableau suivant je peux avoir plusieurs fois 16744 mais je veux savoir si il est sur la ligne du 750154. Si c'est le cas, le couple existe et sur mon premier tableau il met oui dans la case sinon il met non.

Mon probleme est donc lier la recherche dans le 2e tableau.

Pourquoi la formule decaler?
Messages postés
10330
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
4 septembre 2021
1 184
Bonjour ed16091988,
Merci pour la réponse.
Ce que les diverses formules font c'est une chose, par contre ce que vous voulez avoir comme résultat n'est pas précisé !
Désolé de ne pas pouvoir en faire plus.
Messages postés
16499
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 septembre 2021
3 210
Re,
J'ai mis une proposition sur DVP car la bas tes fichiers joints sont + clairs qu'ici....
La prochaine fois, indiques que tu as posé ta question sur d'autres forums et précise lesquels

pour Jean-Pierre:
si tu veux voir la proposition
url de DVP-excel
https://www.developpez.net/forums/f542/logiciels/microsoft-office/excel/
Messages postés
8
Date d'inscription
mercredi 3 décembre 2008
Statut
Membre
Dernière intervention
15 avril 2009

J'avoue ne pas avoir été clair. J'ai réussi a trouvé se que je voulais. Je poste la formule dans le cas ou sa vous intéresserai de savoir se que je voulait vraiment faire.lol


=SI(ESTERREUR(INDEX('[Bond site distant ellipse.xls]Feuil1'!$A:$Z,EQUIV(DROITE(C4,6),'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0),EQUIV(A4,INDIRECT("'[Bond site distant ellipse.xls]Feuil1'!"&EQUIV(DROITE(C4,6),'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0)&":"&EQUIV(DROITE(C4,6),'[Bond site distant ellipse.xls]Feuil1'!$A:$A,0)),0))=A4)=VRAI,"","oui")

Assez compliqué mais performant.
Elle me permet d'afficher "oui" ou "" dans le cas ou le couple est présent sur la deuxième feuille ou non...

Merci quand meme d'avoir pris le temps de tenté de m'aider meme si j'ai eu du mal a expliqué ce que je voulait faire.
Messages postés
16499
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
4 septembre 2021
3 210
Ed,
Excuses moi de t'avoir dérangé en essayant de t'aider
--
Messages postés
10330
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
4 septembre 2021
1 184
Merci.