Installation unzip impossible

[Résolu/Fermé]
Signaler
-
Messages postés
30118
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
-
Bonjour,

j'ai installé, par le biais de VirtualBox, une Debian ETCH 4.0.
J'ai installé LAMP ainsi que le client FTP GFTP.

J'ai downloadé une archive .zip que je voudrais décompresser dans ma Debian. Je tente donc d'installer la commande unzip:

apt-get install unzip


Et là, impossible de finir l'installation, je pense avoir un problème de conflit avec certaines dépendances de GFTP mais je ne sais pas comment solutionner le problème. Voici ce que me renvoi l'install :


Readind package lists ... done
Building dependency tree ... Done

You migth want to run 'apt-get -f install' to correct these :
The following packages have unmet dependencies :

gftp-gtk : Depends : libgtk2.0-0 (>= 2.8.0) But it is not going to be installed
Depends : libpango1.0-0 (>= 1.14.5) But it is not going to be installed

ed
Depends : libwcursor1 (>= 1.1.2) But it is not going to be installed
Depends : libxext6 But it is not going to be installed
Depends : libxi6 But it is not going to be installed
Depends : libxinerama1 But it is not going to be installed
Depends : libxrandr2 But it is not going to be installed

E: Unmet dependencies try 'apt-get -f install' with no packages (or specify a solution)




J'ai essayé plusieurs fois la commande 'apt-get -f install' avec et sans package mais rien n'y fait, je retourne toujours sur le même message lors de l'installation d'unzip.

Note : je rencontre le même problème avec unrar.

Malheureusement, je ne peux pas passer par une archive .gz et il faut absolument que je dézippe cette archive.

Je m'en remet à vous, si vous avez une solution ou des conseils, n'hésitez pas.

Merci d'avance.

Julbo

3 réponses

Messages postés
30118
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
Essaye un :
sudo aptitude update
sudo aptitude upgrade
sudo aptitude install unzip

Je t'invite vivement à utiliser aptitude au lieu d'apt-get, notamment pour éviter ce genre de soucis.

Bonne chance
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
1
Date d'inscription
mardi 17 mars 2009
Statut
Membre
Dernière intervention
18 mars 2009

Bonjour,

Merci beaucoup pour ton aide, j'ai réussi à installer unzip et à régler mes conflits grâce à aptitude. Je ne savais pas que l'usage de apt-get pouvait provoquer ces unmet dependencies.

En tout cas, merci encore pour ta réponse !
Messages postés
30118
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
20 septembre 2021
7 173
Pas de problème, et bonne continuation !