Formule excel avec imbrication

Résolu/Fermé
fdiwa - 4 mars 2009 à 20:41
 fdiwa - 5 mars 2009 à 22:42
bonjour,
Je souhaiterais faire un tableau récapitulatif reprenant 3 transporteurs différents qui me permettrait de déterminer le transporteur le moins cher pour chaque département de la France. Je n'arrive pas à le formuler sur excel
J'ai réussi avec é transporteur mais je ne sais pas comment insérer le 3éme
Avec 2 transporteurs j'ai si a1 est sup à a2 alors A1 sinon a2
Merci pour votre aide

2 réponses

pilas31 Messages postés 1823 Date d'inscription vendredi 5 septembre 2008 Statut Contributeur Dernière intervention 24 avril 2020 634
4 mars 2009 à 23:54
Bonsoir,

Si les tarifs sont en A1, A2 et A3, la formule suivante donne le tarif le plus bas :
=SI(A1<A2;SI(A3<A1;A3;A1);SI(A3<A2;A3;A2))

Si les noms des transporteurs correspondants sont en B1, B2 et B3, le transporteur le moins cher est donné par formule suivante :
=SI(A1<A2;SI(A3<A1;B3;B1);SI(A3<A2;B3;B2))

Bien sur sans utiliser les si imbriqués on peut trouver le min :
=MIN(A1:A3)

A+
1
Bonsoir
merci beaucoup pour ton aide, cela fonctionne!!
trop fort!!!
merci encore
0
Smart91 Messages postés 29092 Date d'inscription dimanche 15 juillet 2007 Statut Contributeur sécurité Dernière intervention 5 avril 2014 2 331
4 mars 2009 à 21:05
Mais tu n'es pas sur le bon forum. Je vais demander à un contributeur de déplacer ta question sur le forum Bureautique

Smart
0