D-Link DWA 110 sous debian

[Résolu/Fermé]
Signaler
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
-
 LAHAMLA -
Bonjour,

ma question est très simple.

J'ai un pc sur lequel j'ai installé une debian etch. je n'ai pas de cable ethernet assez long pour brancher a ma box. j'ai donc acheté un petit dongle D-Link DWA-110. Je veux maintenant pouvoir acceder au net via le dit dongle. mais je n'arrive pas à faire en sorte que ca fontionne.


sachant queje suis nouveau sous linux je vous suis reconnaissant par avance de m'expliquer pas à pas... merci

11 réponses

Messages postés
509
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
15 mai 2010
46
j'ai trouvé ce lien ubuntu, mais valable pour debian:
http://doc.ubuntu-fr.org//wifi_liste_carte?redirect=1

ton dongle est annoté: " Fonctionne out of the box sans aucun problème: c'est plug'n play "
http://doc.ubuntu-fr.org/wifi_liste_carte#d
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
lorsque je fais un lsusb je trouve ca
Bus 003 Device 00207d1:3c07 D-Link System

mais mon dongle n'apparait pas lorsque je fais un iwconfig.

je comprends vraiment pas
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
un peu de nouveau....
je sis passé sur la version 5.0 de debian. sans que cela ne change quoi que ce soit à mon problème d'ailleurs.

je suis allé télécharger le pilote linux pour mon dongle sur le site de d-link.
de là je me suis décidé à suivre pas à pas les instructions du fichiers readme

voila ce que me dit le fichier readme

Build Instructions:
====================
1> $tar -xvzf RT73_Linux_STA_Drv_x.x.x.x.tar.gz
go to "./RT73_Linux_STA_Drv_x.x.x.x/Module" directory.

2> $cp Makefile.4 ./Makefile # [kernel 2.4]
or
$cp Makefile.6 ./Makefile # [kernel 2.6]

3> [kernel 2.4]
$chmod 755 Configure
$make config # config build linux os version

4> $make all # compile driver source code
4.1> $make install

5> $cp rt73.bin /etc/Wireless/RT73STA/ # copy firmware

6> $dos2unix rt73sta.dat
$cp rt73sta.dat /etc/Wireless/RT73STA/rt73sta.dat
# !!!check if it is a binary file before loading !!!

7> $load
#[kernel 2.4]
# $/sbin/insmod rt73.o
# $/sbin/ifconfig rausb0 inet YOUR_IP up

#[kernel 2.6]
# $/sbin/insmod rt73.ko
# $/sbin/ifconfig rausb0 inet YOUR_IP up

les étapes 1 et 2 se passent sans encombre. je zappe l'étape 3 étant donné que j'ai le kernel 2.6 (vérifié avec la commande uname -r). et quand je fais un make all j'obtiens cette réponse :

make -C /lib/modules/2.6.26-1-686/build \
INSTALL_MOD_DIR=extra SUBDIRS=/home/keneichi/20071128_DWA_TR73_Linux_STA_Drv1.0.4.0/Module \
modules install
make: *** /lib/modules/2.6.26-1-686/build: Aucun fihier ou repertoire de ce type. Arrêt.
make: *** [install] Erreur 2

je comprends pas pkoi en suivant scrupuleusment les indications du fichier readme j'ai une erreur...

si quelqu'un accepte de m'aider j'en serais ravi....
Messages postés
509
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
15 mai 2010
46
il est essentiel d'installer les packages:
linux-source
linux-headers
Les as tu installés?
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
non je neles ai pas installé...

que font précisément ces paquets?
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
ca y est je les ai installé.

ceci dit ca ne change rien à mon problème. le./configure me dit toujours permission non accordée

par contre le message d'erreur de make all a changé.
voila ce que j'ai désormais :

make -C /lib/modules/2.6.26-1-686/build SUBDIRS=/home/keneichi/20071128_DWA110_RT73_Linux_STA_Drv1.0.4.0/Module modules
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.26-1-686 »
scripts/Makefile.build:46: *** CFLAGS was changed in "/home/keneichi/20071128_DWA110_RT73_Linux_STA_Drv1.0.4.0/Module/Makefile". Fix it to use EXTRA_CFLAGS. Arrêt.
make[1]: *** [_module_/home/keneichi/20071128_DWA110_RT73_Linux_STA_Drv1.0.4.0/Module] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.26-1-686 »
make: *** [all] Erreur 2

je sais pas si ca va vous aider m'orienter
Messages postés
509
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
15 mai 2010
46
je te confirme que ton dongle a besoin du pilote ralink rt73
http://wiki.backtrack-fr.net/index.php/Compatibilit%C3%A9_Mat%C3%A9rielle

tu as essayé de l'installer via Synaptic?
l'avantage de l'installation via Synaptic est que cet utilitaire gère les dépendances
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
merci pour ces précieuses information laprune04, mon problème est enfin solutionné ! je réponds d'ailleurs depuis mon pc debian en wifi... ca fait plaisir de voir que ca marche... :):):)

petit récapitulatif.
J'ai donc installé les paquets linux-source et linux-headers. ensuite j'ai suivi les instructions données à cette adresse

http://forum.backtrack-fr.net/viewtopic.php?pid=14914#p14914

et pour ma part en suivant pas à pas les iinstruction ca a marché impéccablement.... ce que j'ai apprécié dans le topic sur le forum backtrack c'est que le gars explique très clairement a quoi correspond la chaque commande qu'il dit de réaliser...

j'aurais juste aimer savoir à quoi servait les deux pemier paquet que j'ai installé... :)


Messages postés
509
Date d'inscription
jeudi 18 septembre 2008
Statut
Membre
Dernière intervention
15 mai 2010
46
La réponse est dans Synaptic, dans la description du package sélectionné (bas de Synaptic) ;)

de son côté, wikipedia.org dit:
https://en.wikipedia.org/wiki/Linux_kernel#Kernel_headers
"Kernel headers

Kernel headers are C header files which provide some definitions of the low-level kernel ABI, to be shared between the kernel and userspace programs. Most userspace programs should not include kernel headers; they are only intended to be used directly by system libraries and low-level tools and daemons.[52]

The "make headers_install" command, when executed in the kernel's source tree, exports the kernel's header files in a form suitable for use by userspace programs.[53]

When exported, most kernel headers reside in the /usr/include/asm and /usr/include/linux directories."
Messages postés
294
Date d'inscription
vendredi 4 mai 2007
Statut
Membre
Dernière intervention
26 mai 2010
9
oups.... désolé je suis pas passé par le gestionnaire de paquet pour l'install... je suis passé par le terminal administrateur avec un apt-get...
:)
Bonjour,


J'ai le même problème que toi avec mon debian et ma clé DWA-110 "qu'on m'a conseillé vivement pour faire du wifi avec mon linux" si tu as une réponse fait tourner stp, je te serais vraiment reconnaissant.

Merci d'avance