[excel] valeur d'une cellule dans un lien [Résolu/Fermé]

Signaler
-
 joniyyy -
Bonjour,

J'aurais voulus savoir comment insérer la valeur d'une cellule dans le lien d'un document?

Voici un exemple pour vous expliquer:
'\\Be\commun\07-BUREAU ETUDE\calcule de canalisation\316L\[Canalisation.xlsx]1,6mm'!$A$2:$B$26
A la place de 316L, je voudrais que ce soit la valeur d'une cellule où je rentre cette valeur.

Je sais pas si c'est trés clair comme explication...
Merci d'avance pour votre aide.

7 réponses

Messages postés
16369
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
8 août 2020
9 609
Bonjour,

Je sais pas si c'est trés clair comme explication...

Pas pour moi en tous les cas !!! :D

Réexplique plus clairement et n'oublie de dire sur quel logiciel tu travailles, ainsi que la version.

m@rina
Je suis sous office 2007.

En faite, dans le lien que j'ai donné, je voudrais que à la place de marquer 316L ce soit la valeur de la cellule H2 (par exemple) qui soit prise.
Messages postés
1925
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
7 juillet 2020
793
Bonjour,

une concaténation te suffirait-elle?

="\\Be\commun\07-BUREAU ETUDE\calcule de canalisation\"&H2&"\[Canalisation.xlsx]1,6mm'!$A$2:$B$26"

cordialement
Non

Quelqu'un d'autres?
Messages postés
1925
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
7 juillet 2020
793
Pourtant ça marche chez moi

j'ai mis "google" dans une cellule (B345) et j'ai mis =LIEN_HYPERTEXTE("http://www."&B345&".fr";"google")
le résultat est un lien vers le moteur de recherche

A+
Ce que j'ai oublié de dire, c'est que ce lien permet de donnée une table pour une recherche.Voila la formule complète, avec ta solution (le lien à changé, mais c'est normale, je ne suis plus au bureau):

=RECHERCHEV(B3;'C:\Documents and Settings\seb\Bureau\calcule de canalisation\"&H2&"\[Canalisation.xlsx]1,6mm'!$A$2:$B$26;2;FAUX)
Messages postés
1925
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
7 juillet 2020
793
Bonsoir,

Avec INDIRECT.EXT() peut-être.
C'est une fonction de la bibliothèque MOREFUNC (http://xcell05.free.fr/) de Laurent LONGRE.
C'est une bibliothèque très utile qui comble des lacunes d'Excel.

Si le classeur était ouvert, INDIRECT() suffirait.

Cordialement
C'est exactement çà

J'ai trouvé cette solution dans les tuto de dévellopper.com, il y a plein de truc intéressant.

Merci de votre aide.