Pb comprehension formule Excel 2003

Résolu/Fermé
Signaler
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
-
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
-
Bonjour,
J'ai un petit soucis de comprehension sur la formule suivante :

=SOMMEPROD((Saisie!C6:C13="OUI")*(Saisie!G6:G13>=Synthèse!G1)*(Saisie!G6:G13<=Synthèse!J1)*(MOIS(Saisie!H6:H13)>=1)*(MOIS(Saisie!H6:H13)<=3))

En colonne C de la feuille Saisie, j'ai OUI
En colonne G de la feuille Saisie, ma valeur (date) est bien située entre les bornes G et J de la feuille Synthese
En colonne H de la feuille Saisie, je n'ai rien et pourtant le resultat me donne 1
Par contre, lorsque je rentre une date, le résultat tombe à 0

J'ai essayé de remplacer SOMMEPROD par SOMME, essayé les deux en matricielles, mais chaque fois le résultat attendu est erroné. Soit j'ai 0 et je devrais avoir 1 soit l'inverse.

Quelqu'un pourait m'expliquer ou je me suis planté?

J'ai enlevé les signes $ pour le confort de lecture, mais ils sont bien présent dans ma formule (en fait tout est figé)

Merci

7 réponses

Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
242
bonjour

difficile à te répondre sans un fichier exemple, la formule semble correcte et comme cela à premiere vue, il se pourrait que cela soit du aux parametres G1 et J1 qui ne serait pas remplis ... mais sans le classeur pour tester ajoute une condition : (Synthèse!G1*synthèse!J1>0), si une des dates n'est pas remplie, le resultat sera = à zero
Messages postés
16538
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
1 décembre 2021
3 252
Bonjour mabelle, Wilfried
bizarre
J'ai réalisé une maquette de ta formule: ca marche
je la joins à tout zazar si ça peut t'aider...
http://www.cijoint.fr/cjlink.php?file=cj200901/cijo6A4ACE.xls
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Le fichier en exemple (encours d'élaboration)
http://www.cijoint.fr/cjlink.php?file=cj200901/cijV0KPoZe.xls
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Oups
La formule qui me pose pb est en J9 de la feuille Synthese
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
242
re:, salut Michel

avec un fichier c'est plus facile lol et c'est normal : dans la colonne H, mois de la feuille saisie, tu n'as rien donc 0 en numerique : en format date : 0 et 0 en format date donne 00/01/1900 soit le mois de janvier
il te faut rajouter un test : * (H6:H13>0)
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Merci beaucoup
Le pire est que j'avais pensé remplacer le >=1 par >0 mais sans le faire
Je vais plutôt opter pour cette dernière afin de réduire la longueur de ma formule
Encore merci à tous
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Ben finalement non. Si je place >0 en lieu et place de >=1 dans ma condition mois, j'ai à nouveau l'erreur.
Il faut donc que je place un nouveau test comme préconisé par Wilfried42
Messages postés
907
Date d'inscription
mardi 19 août 2008
Statut
Contributeur
Dernière intervention
8 décembre 2009
242
re:

je crois avoir dit ajourter une condition : mois(0) donnant 1 que tu mettes >0 ou >=1 c'est pareil
=SOMMEPROD((Saisie!$C6:$C13="OUI")*(Saisie!$G6:$G13>=Synthèse!$G$1)*(Saisie!$G6:$G13<=Synthèse!$J$1)*(MOIS(Saisie!$H6:$H13)>=1)*(MOIS(Saisie!$H6:$H13)<=3)*(Saisie!$H6:$H13>0))
Messages postés
469
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
21 juin 2017
125
Re
Oui effectivement
dans la precipitation, on oubli de voir les évidences ... lol