Recherche formule excel pour calcul nb cellul [Résolu/Fermé]

Signaler
-
 jetsteph57 -
Bonjour,
j'ai un tableau excel contenant plusieur colonne : la 1 ere contient le nom,la 2 ème la date ,la 3 eme une offre
je cherche a calculer le nombre de nom de la 1ere colonne avec comme critere un ceratine date et une certaine offre
exemple nb de jean qui a la date 12/11/2008 on eu une offre N°5
j'espere etre comprehensible

merci d'avance

4 réponses

Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 109
bonjour

Avec ton nom cherché en D1, ta date cherchée en E1, ton offre cherchée en F1, le comptage sur les 100 premières lignes peut se faire avec cette formule :

=SOMMEPROD((A1:A100=D1)*(B1:B100=E1)*(C1:C100=F1))

Toutes les plages de ta formule doivent avoir la même taille et c'est beaucoup mieux d'avoir des plages nommées avec la fonction DECALER car ainsi le calcul se fait sur la plage appropriée :

"noms" : = DECALER($A$1;;;NBVAL(A:A);1) par exemple
"dates" : = DECALER($B$1;;;NBVAL(A:A);1) par exemple
"offres" : = DECALER($C$1;;;NBVAL(A:A);1) par exemple
en comptant toujours la même colonne, pour avoir la même taille de plage.

et la formule devient :

=SOMMEPROD((noms=D1)*(dates=E1)*(offres=F1))
merci pour votre reponse c'est ce que je recherche peut etre avec juste une petite amelioartion:
comment faire pour que je selectionne une plage de date (ex : du 12/11/2008 au 12/12/2008)
merci
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 109
bonjour

Tu rajoutes un test :

=SOMMEPROD((noms=D1)*(dates>=E1)*(dates<=E2)*(offres=F1))
Messages postés
52050
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
4 août 2020
13 830
Si tu avais Excel 2007, tu pourrais utliser la fonction SOMME.SI.ENS
bonjour,
merci a tous j'ai reussi grace a votre aide