Redémarrage de apache en ligne de commande

Bonjour,
J'aimerai ajouter dans les taches de windows le redémarrage de apache toutes les 30 minutes mais le soucis c'est que je dois trouver la commande pour restart apache en ligne de commande, j'ai essayé :
C:\wamp\bin\apache\apache2.2.14\bin httpd.exe -k restart     


Car c'est le fichier qui permet de gérer apache mais cette commande marche pas,
l'erreur suivante apparait :
     
[Mon Oct 18 16:48:40 2010] [error] (OS 2)Le fichier spÚcifiÚ est introuvable.  :     
 No installed service named "Apache2.2".     


Alors que apache est bien installé vu que je m'en sert ...

J'ai même essayé de me placer dans le dossier et de faire
     
httpd.exe -k restart 


Mais sans résultat et avec la même erreur.

Si quelqu'un pouvait m'aider sur ce point en me donnant une solution pour redémarrer apache en ligne de commande, ça serait gentil.

2 réponses

  1. Merci énormément, je suis dégouté car ca fait 1 semaine que je cherche, j'avais pas installé avec -k install -_-
    1. donc ton problème s'est résolu ? Cool alors !

      merci de mettre ta question à RÉSOLU

      Bonne fin de journée
  2. slt,

    en anglais , mais assez complet semble t-il : http://httpd.apache.org/docs/2.1/fr/platform/windows.html#winsvc

    check en même temps si ton installation a été faite comme conseillé ! il faut que tu l'aies installé comme un service...
    !! Vulcan

    Il n'y a pas que les aigles qui atteignent les sommets, les escargots aussi, mais ils en
    bavent !