Problème nfs

Résolu
Bonjour,

je n'arrive pas à monter mon réseau nfs entre deux machines linux.

coté client(machine Corinne):
/etc/hosts:
127.0.0.1 localhost
127.0.0.1 ordicor.chezcor.cheznous ordicor
192.168.0.1 pcmat.chezmoi.cheznous pcmat
192.168.0.2 Corinne.chezcor.cheznous Corinne

/etc/hosts.allow:
ALL:192.168.0.1
ALL:192.168.0.2

/etc/hosts.deny
ALL:ALL

coté serveur(machine pcmat):
/etc/hosts:
127.0.0.1 localhost
127.0.0.1 ordifix.chezmoi.cheznous ordifix
192.168.0.1 pcmat.chezmoi.cheznous pcmat
192.168.0.2 Corinne.ordicor.cheznous Corinne
192.168.0.3 macthomas.cheztom.cheznous macthomas

/etc/exports
/home/matser Corinne(rw,subtree_check,insecure)

/etc/hosts.allow
ALL:192.168.0.2

/etc/hosts.deny
ALL:ALL

sur le serveur je tape (je suis sous slackware):
/etc/rc.d/rc.nfsd

sur le client:
mount -t nfs 192.168.0.1:/home/matser /mnt/net

et cette commande me répond:
mount.nfs: mount to NFS server '192.168.0.1:/home/matser' failed: RPC Error: Program not registered

quelqu'un a une idée?
Configuration: Linux
Firefox 3.0.10

5 réponses

  1. salut,

    aïe, ça recommence malgré l'utilisation du noyau 2.6.30.1.
    En fait je l'ai à nouveau résolu en remplaçant le nom des machines par leur adresse IP dans /etc/exports
    # See exports(5) for a description.
    # This file contains a list of all directories exported to other computers.
    # It is used by rpc.nfsd and rpc.mountd.
    
    /home/matser             192.168.0.2(rw,subtree_check,insecure)
    /home/matser/musique     192.168.0.3(rw,subtree_check,insecure)
    /home/matser/audio-video 192.168.0.3(rw,subtree_check,insecure)
    /home/matser/mp3         192.168.0.3(rw,subtree_check,insecure)
    
    1. salut,

      ce problème n'existe plus à partir du noyau 2.6.30.
      Ils ont enlevé l'option "Register local RPC services via rpcbind v4" et nfs fonctionne entre les deux ordis
      1. salut à tous!

        j'ai trouvé la soluce: il faut désativer dans le noyau "Register local RPC services via rpcbind v4"

        menu File systems  --->
           sous-menu [*] Network File Systems  --->
             décocher [ ]   Register local RPC services via rpcbind v4 (EXPERIMENTAL)
        1. Modérateur
          Merci :-))
      2. salut,

        dans le script d'initialisation /etc/rc.d/rc.nfsd, il y a "exportfs -r"
        exportfs
        /home/matser Corinne.chezcor.cheznous

        sur le client:
        mount -t nfs 192.168.0.1:/home/matser /mnt/net
        mount.nfs: mount to NFS server '192.168.0.1:/home/matser' failed: RPC Error: Program not registered


        ça te dit quelque chose?
        1. sinon, comment active-t-on le portmap? (je suis sous slackware)
        2. Modérateur
          @matser1973Il doit y avoir un script dans /etc/rc.d/ non ?
        3. @jipicyc'est dans /etc/rc.d/rc.rpc, qui est activé.
          /etc/rc.d/rc.rpc restart
          Starting RPC portmapper:  /sbin/rpc.portmap
          Starting RPC NSM (Network Status Monitor):  /sbin/rpc.statd
          mount -t nfs 192.168.0.1:/home/matser /mnt/net
          mount.nfs: mount to NFS server '192.168.0.1:/home/matser' failed: RPC Error: Program not registered
      3. Modérateur
        Salut,

        Le service "portmap" est-il démarré ?

        As-tu exporté le répertoire avec la commande :
        exportfs -a
        Que renvoie la commande :
        exportfs
        sur le serveur ?