Probleme dns bind

Résolu
Bonjour,

je sollicite votre aide car je n'arrive pas à faire fonctionner mon dns
j'ai une RedHat EL 5 et j'utilise bind, mon dns est configuré en secondaire, il se repplique sur un 2003 srv

en regardant les log je peut confirmer qu'il charge bien mon fichier /etc/named.conf puis il me marque l'erreur suivante :
named.ca:1: no current owner name
could not configure root hints from 'named.ca' : no owner
loading configuration: no owner
exiting (due to fatal error)

mon fichier named.ca et
3600000 IN NS dns1.mon.domaine.fr.
dns1.mon.domaine.fr 3600000 IN A A.B.C.D1
3600000 IN NS dns2.mon.domaine.fr.
dns2.mon.domaine.fr 3600000 IN A A.B.C.D2

j'ai bien mis named en tant que proprietaire du repertoire /var/named

merci de votre aide
Configuration: Windows XP
Firefox 3.0.6

1 réponse

  1. Contributeur
    Tu pourrais poster le named.ca complet stp ?

    Merci !

    1. il est complet mon fichier named.ca ne contien que sa :

      3600000 IN NS dns1.mon.domaine.fr.
      dns1.mon.domaine.fr 3600000 IN A A.B.C.D1
      3600000 IN NS dns2.mon.domaine.fr.
      dns2.mon.domaine.fr 3600000 IN A A.B.C.D2
    2. @jerem1985c'est bon j'ai trouver
      j'avais oublier les @

      sa :

      3600000 IN NS dns1.mon.domaine.fr.
      dns1.mon.domaine.fr 3600000 IN A A.B.C.D1
      3600000 IN NS dns2.mon.domaine.fr.
      dns2.mon.domaine.fr 3600000 IN A A.B.C.D2

      devient :

      @ 3600000 IN NS dns1.mon.domaine.fr.
      dns1.mon.domaine.fr 3600000 IN A A.B.C.D1
      @ 3600000 IN NS dns2.mon.domaine.fr.
      dns2.mon.domaine.fr 3600000 IN A A.B.C.D2
    3. Contributeur
      @jerem1985C'est tout ?

      Où est le SOA ?
      L'adresse de contact ?
      Le TTL ?

      Il manque des choses pour que ça puisse marcher, je crois.

    4. @HostOfSeraphimle TTL et le SOA sont préciser dans mon named.local

      si tu veut ma conf se compose comme sa :

      dans /etc/named.conf : la conf global du dns ou je déclare
      - address ip et port ecoute, clef et algorithm pour replication etc
      - repertoire de fichier de zone (/var/named ou /var/named/chroot si tu est chrooter)
      - ma zone cache
      zone "." {
      type hint;
      file "named.ca";
      };
      - ma resolution localhost en 127.0.0.1
      zone "0.0.127.in-addr.arpa" {
      type master;
      file "named.local";
      };
      - est mes declaration de domaine et zone inverse

      mon fichier named.ca contient les bon :-) parametres du post précdent

      et mon fichier named.local est comme suit
      $TTL 1d
      @ IN SOA localhost. root.localhost. (
      2009022601
      3h
      1h
      1w
      1h
      )
      IN NS localhost.
      1 IN PTR localhost.

      tous mes fichiers de domaine et reverse zone déclarer en secondaire dans le fichier /etc/named.conf sont récuperé sur mon dns primaire