Problème connexion client XP -> PDC samba [Résolu/Fermé]

Signaler
Messages postés
19
Date d'inscription
jeudi 18 décembre 2008
Statut
Membre
Dernière intervention
13 janvier 2009
-
 nicedata -
Bonjour,

Je suis un nouveau débutant sur linux et j'ai un problème avec mon installation de PDC samba, sur Debian. A présent, j'arrive à joindre mon poste client XP sur le domaine linux, cependant, ensuite, je n'arrive pas à ouvrir une session dessus.
Lorsque je tape mon nom d'utilisateur, mot de passe et que je choisis mon domaine, il me dit que le poste ne peut pas se connecter au car le domaine est indisponible ou ne fonctionne pas, ou que le compte utilisateur est non trouvé.

Je ne comprend pas, j'ai pourtant bien crée mon utilisateur martin avec un mot de passe martin en faisant :

adduser martin
smbpasswd -a martin
et ma machine est bien ajoutée aussi , j'avais effectué un :
adduser pc_info$
smbpasswd -a -m pc_info

cela fait maintenant 4 jours que je cherche désespérément des réponse au naviguant sur différents forum mais impossible de résoudre le problème.

voici mon fichier smb.conf :

[global]
name resolve order = wins bcast hosts
passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n *password\supdated\ssuccessfully* .
admin users = root
passwd program = /usr/bin/passwd %u
netbios name = Debian
invalid users =
remote announce = 192.168.0.133/essaist.lan
workgroup = essaist.lan
os level = 33
security = user
add machine script = /usr/sbin/useradd -d /dev/null -g machines -s /bin/false -m %u
log file = /var/log/samba/log.%m
smb passwd file = /etc/samba/smbpasswd
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
domain master = yes
username map = /etc/samba/smbusers
interfaces = 192.168.0.133/24 eth2
winbind use default domain = Yes
wins support = yes
server string = %h server
unix password sync = yes
logon path = \\debian\%U\profile
add user script = /usr/sbin/adduser --quiet --disabled-password --gecos "" %u
valid users = root martin
preferred master = yes
domain logons = yes
local master = yes

[donnees]
path = /home/samba/donnees
comment = Partage Donnees
writeable = Yes
browseable = Yes
valid users =

[homes]
path = /home/samba/home/%u
comment = Home Directories
browseable = no
writeable = Yes
create mode = 0700
directory mode = 2700
valid users = %S
guest ok = no

[netlogon]
path = /home/samba/netlogon
guest ok = no
browseable = no
read only = Yes
valid users = %U #@sambausers

[profiles]
comment = Users profiles
path = /home/samba/profiles
guest ok = no
browseable = no
create mode = 0600
directory mode = 0700
valid users = %U #@sambausers
writeable = Yes


voila un extrait du fichier log.smbd :

[2008/12/18 18:41:07, 0] smbd/service.c:make_connection_snum(849)
Can't become connected user!
[2008/12/18 18:49:07, 0] smbd/service.c:make_connection_snum(849)
Can't become connected user!


un smbclient :

debian:/home/stagiaire# smbclient \\\\essaist.lan\\martin -U martin
Error connecting to 0.117.222.183 (Argument invalide)
Connection to essaist.lan failed

un testparm :

debian:/home/stagiaire# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[donnees]"
Processing section "[homes]"
Processing section "[netlogon]"
Processing section "[profiles]"
Processing section "[printers]"
Processing section "[print$]"
Processing section "[cdrom]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC
Press enter to see a dump of your service definitions

et enfin un extrait de mon fichier smbpasswd :

root:0480EA9533C500D4AAD3B435B51404EE:329153F560EB329C0E1DEEA55E88A1E9:[U ]:LCT-4948EF6D:
martin:1002:CB829955C5787ACAAAD3B435B51404EE643DA71A76DD7EB97226D3C5AFEB01B:[U ]:LCT-494A825C:
pc_info$:1003:4288A8C89EBF1350AAD3B435B51404EE:0F482A39D7C16E1B9BFA55BD24A03108:[W ]:LCT-494A836F:


Pouvez vous m'aider ?

Merci

1 réponse

Messages postés
19
Date d'inscription
jeudi 18 décembre 2008
Statut
Membre
Dernière intervention
13 janvier 2009

bonjour,
après pas mal de recherche, j'ai enfin réussi a joindre correctement mon domaine et ouvrir une session
le problème était que j'avais des erreurs dans les lignes de mon smb.conf et quelques lignes inutiles.
Les ouvertures de session fonctionnent à présent correctement.
Merci quand meme
Salut,

Serait-il possible de me dire ce qui n'allait pas dans ton fichier smb.conf, car j'ai le même problème et je n'arrive pas à m'en sortir.

Merci
Même souci ici :-) On aimerait bien profiter de cette piste pour corriger le tir...