Valeur dernière cellule non vide [Résolu/Fermé]

Signaler
-
 dd -
Bonjour,
Bonjour
J’ai un tableau de ce style :
A	  C

1	  X
2	  X
(vide)  (vide)
3	  X
(vide)  (vide)
4	  X
(vide)  (vide)
(vide)  (vide)
5	  X


Lorsqu’il y a une valeur alphanumérique dans la colonne C, je dois numéroter la ligne dans la colonne A.
J’aimerai créer une fonction (sans VBA si possible) qui me permettra de numéroter ces lignes et donc qui sauterai les lignes vides en colonne C…

Pour cela, il me faut récupérer la valeur de la dernière cellule non vide et l'utiliser directement. J’aimerai inscrire cette instruction directement dans le corps de ma fonction.

Voici ce que j’ai pu écrire grâce à l’aide de forum tels que celui-ci :
=OU(SI(C62<>"";A61+1;"");SI(A61="";INDEX(A:A;MAX(COLONNE(A:A)*NON(ESTVIDE(A:A)))-COLONNE(A:A)+1)+1;A61+1))

Résultat : ###

Merci d’avance pour votre réponse.
Adrien.
    

2 réponses

Mais dit moi c'était intéressant ça...
Mettre un ballon dans un panier c'est le seul problème qu'il y a dans ta vie ou tu kiffes galérer à lire les problèmes des autres et faire le surhomme derrière ton clavier?
Il est tard, va te coucher gamin...
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Ok bon, pour ceux que ça intéresse, j'ai trouvé une solution qui me convient:

=SI(C62<>"";RECHERCHE(9^9;$A$57:A61)+1;"")

Salut.
c'est toi qui devrait aller te coucher
t'es complexé mon gars
Messages postés
22
Date d'inscription
mercredi 20 août 2008
Statut
Membre
Dernière intervention
15 juillet 2010
1
intello