Excel - suite conditionnelle fct du temps

Fermé
syl - 27 oct. 2008 à 17:03
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 - 28 oct. 2008 à 12:17
Bonjour,

Je tourne sous excel 2003 qui limite les suite de conditionnelle à 7, hors je cherche à créer une suite de condition fonction du temps du type:

Temps = T
3 valeurs en fonction du temps : X, Y, Z

Si(T>0;X;Si(T+10>0;Y;Si(T+20>0;Z;Si(T+30>0;Y;Si.......


Concrètement ca se traduit par :

t+0 t+10 t+20 t+30 t+40 t+50 t+60
______________________________________________________________________________..........>
X Y Z Y Z Y

Y a t il un moyen de contourner cette limite de formulation conditionnelle ? sachant que j'ai besoin d'imbriquer environ 15 conditions

Merci
A voir également:

5 réponses

jonathan master
27 oct. 2008 à 17:23
Bonjour

Peut être l'option consisterait à scinder en 3 cellules ta fonction "SI" et après faire une 4ème qui reprend le résultat. Certes, ce n'est pas top, mais après tu peux masques tes 3 cellules qui contiennent la formule conditionnelle et n'afficher que celle du résultat.

Enfin, c'est ce que je vois comme solution.. il y a surêment d'autres..

Bon courage
0
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 7 217
28 oct. 2008 à 09:07
Bonjour,

Construire une table avec tes valeurs (sans la 1ère) en $C$1:$D$6 :
C                 D
0	         Y
10.0000000000001	Z
20.0000000000001	Y
30.0000000000001	Z
40.0000000000001	Y
................................

la formule :
=SI(A2>0;"X";RECHERCHEV(-A2;$C$1:$D$6;2;VRAI))

eric
0
g Messages postés 1262 Date d'inscription vendredi 23 avril 2004 Statut Membre Dernière intervention 15 mai 2017 572
28 oct. 2008 à 09:30
Bonjour,

Tu peux conditionner ta fonction autant de fois que tu le désires en la nommant.
Si tu veux connaitre le procédé vas sur http://gerard.g.pagesperso-orange.fr/logexl_05_a.htm#nom_formule.

Bonne journée.
0
Humm, les idées sont très intéressantes, surtout celles pour nommer la fonction. J'ai oublié de donner un élement cependant.

Cette formule doit etre répliquée dans un tableau de 400 lignes*5 colonnes et je me sens mal de devoir tout taper à la main :D

Enfin, je pense que le plus simple va être de passer sous excel 2007.

Merci de vos réponses.
0
eriiic Messages postés 24571 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 19 mai 2024 7 217
28 oct. 2008 à 12:17
As-tu seulement essayé ce que je te propose au post 2 ????

Et pour ce qui est de la recopie, que ce soit excel 2003 ou 2007, il faut utiliser la recopie incrémentée en cliquant-glissant le petit carré noir en bas à droite de la cellule sélectionnée
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
g Messages postés 1262 Date d'inscription vendredi 23 avril 2004 Statut Membre Dernière intervention 15 mai 2017 572
28 oct. 2008 à 10:42
Ce n'est pas un problème, car la formule tu ne la saisis qu'une seule fois.
Ensuite tu n'as qu'à recopier son nom sur l'ensmble de la plage concernée.

Bonne suite.
0