Linux gentoo installation mysql

Résolu/Fermé
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
- 22 oct. 2008 à 05:04
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
- 22 oct. 2008 à 13:58
Bonjour,

Je craque: j'ai suivi a la lettre ce que disait le site officiel pour installer mysql et tout se passe bien sauf qu'à la fin il me met error 1045
acces denied for user 'root'@'localhost'(using password YES')

Que dois je faire?

Merci pour votre aide car je suis a bout!

9 réponses

dindoun
Messages postés
1027
Date d'inscription
mercredi 23 janvier 2008
Statut
Membre
Dernière intervention
17 février 2017
137
22 oct. 2008 à 08:46
salut
j'utilsie ça sous ubuntu

sudo apt-get install php5 apache2 apache2-mpm-prefork libapache2-mod-php5 php5-mysql php5-gd php5-cli mysql-server mysql-client mysql-common libmysqlclient15off libapache2-mod-auth-mysql php5-cgi php5-cli &&  
sudo chmod a+w /var/www/ && cd /etc/php5/apache2/
sudo chmod 777 php.ini && cat php.ini|sed "s/max_execution_time = \([0-9]*\) /max_execution_time = 3000 /" |sed "s/max_input_time = \([0-9]*\) /max_input_time = 6000 /" > php.ini && sudo chmod 644 php.ini && sudo /etc/init.d/apache2 restart && sudo apt-get install phpmyadmin
0
bob031
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
471
22 oct. 2008 à 10:33
salut,

tout se passe bien sauf qu'à la fin il me met error 1045
acces denied for user 'root'@'localhost'(using password YES')


le message d'erreur, c'est après avoir fait quoi exactement ?


as-tu essayé ceci dans une console :
#mysql -u root -p
0
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
5
22 oct. 2008 à 12:25
bonjour,
je voulais tester si mysql fonctionne ou pas, alors j'ai tapper la fameuse commande
shell> mysql -u root -h localhost -pmotdepasse
et aussi la commande
shell> mysql -u root -h localhost -p
qui me permet de saisir le mot depasse
et aussi
shell> mysql -u root -h localhost
et aussi
shell> mysql -u root
et aussi
shell> mysql
la meme erreur avec une différance :
si je fourni le mot de passe l'erreur donne à la fin ==> (using password YES)
sinon elle donne à la fin ==> (using password NO)


je ne suis pas arrivé à l'etape du serveur apache ou lighhtp :(
juste mysql sous linux
aidez moi svp
je n'arrive pas a avoir la ligne de commande mysql ==> mysql>
alors je ne peut rien faire,
et je crois que la table user est vide !!!
comment je pourais vérifier !!
0
bob031
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
471
22 oct. 2008 à 12:59
est ce que mysql est lancé au moins ?

que donne la commande :
#mysql -u root -p
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
5
22 oct. 2008 à 13:04
mysql est lancer

voila le detail :
localhost ~ # /etc/init.d/mysql restart
* Stopping mysql ...
* Stopping mysqld (0) [ ok ]
* Starting mysql ...
* Starting mysql (/etc/mysql/my.cnf) [ ok ]
localhost ~ # mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)
localhost ~ #
0
bob031
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
471
22 oct. 2008 à 13:12
ok ! et ceci :

#mysqladmin -u root password "ton_mot_de_passe"

0
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
5
22 oct. 2008 à 13:14
oui je l'ai testes et voila ce qu'il me donne :
je précise que mysql est démarrer ... ==>


localhost ~ # /etc/init.d/mysql restart
* Stopping mysql ...
* Stopping mysqld (0) [ ok ]
* Starting mysql ...
* Starting mysql (/etc/mysql/my.cnf) [ ok ]
localhost ~ # mysqladmin -h localhost -u root password "test"
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: NO)'
localhost ~ #
0
bob031
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
471
22 oct. 2008 à 13:27
ok ! et ceci :

#mysqladmin -u root -p password "un_nouveau_mot_de_passe"

dans un premeir temps, ne pas mettre l'option -h localhost
0
developper_man
Messages postés
44
Date d'inscription
mardi 21 octobre 2008
Statut
Membre
Dernière intervention
14 novembre 2008
5
22 oct. 2008 à 13:58
ça aussi ça ne marche pas
j'ai dis que la table user est vide
comment modifier un mot de passe d'un user qui n'existe pas !!!!
alors comment ajouter un utilisateur et comment lui donner les droits qu'il faut
et comment faire cela sachant que je n'ai pas accées à mysql
est ce qu'il y moyen de forcer la connecxion sans avoir le droits !!!
0