Regrouper des données en fonction d'1 chiffre

Résolu/Fermé
Signaler
Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
-
Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
-
Bonjour,

J'utilise actuellement excel pour le boulot et on m'a filé une liste du nombre d'employé en fonction des differents sites de la boite.

Je suis faire des groupes de 2000 employés et je sais pas du tout comment on s'y prend, je n'ai aucune idée de la formule à rentrer.

Je vous remercie d'avance.

8 réponses

Messages postés
17300
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
3 décembre 2021
10 744
Bonjour,

Euh... tu peux être plus explicite ? Ca manque de détails, quand même...

m@rina
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
1
Désolé, alors voilà :

J'ai une premiere colonne qui contient le nom de chaque ville où l'entreprise possède des bureaux.
Et dans la colonne à côté j'ai le nombre d'employé basé dans chacune de ces villes.

Exemple :

Berlin 1500
Los Angeles 500
Paris 165
New York 322
Dallas 64
Londres 22
....


Je dois regrouper ces employés en groupe de 2000 personnes, donc dans l'exemple ci-dessus j'aurai dans le premier groupe Berlin + Los Angeles

Voilà, j'espère que vous m'avez compris :-)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 980
Bonjour tout le monde,

Tu peux faire ainsi :
- tes données à partir de A2 et B2
- en C2 =SI(C1<2000,B2+C1,B2) fais la somme des villes avec raz si somme précédente>=2000
- en D2=SI(C2>C1,D1,D1+1) donne un numéro de groupe de 0 à ...

eric
Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
1
Bonjour,

Merci beaucoup,

J'ai oublié de préciser qu'au bureau on utilisait la version US d'excel et donc tout est en anglais, pour retrouver la formule "SI", pas de problème, c'est "IF".

Mais par contre pour RAZ, je ne connais pas son equivalent anglais, je vais faire des petites recherches de mon côté mais si vous pourriez m'expliquer en détail la procédure "fais la somme des villes avec raz si somme précédente>=2000", ce serait SUPER.


Encore une fois merci beaucoup pour l'aide que vous m'avez apporté jusqu'à maintenant.
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 980
c'était juste l'explication de la formule... raz= remise à zéro.
Bon, c'est vrai que si j'avais écrit ': fait' au lieu de 'fais' la compréhension aurait été meilleure ;-)

La formule est:
=SI(C1<2000,B2+C1,B2)
c'est tout
Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
1
Parfait, ça marche...

J'aimerai savoir si il est possible de programmer excel pour réunir tous ces employés en paquets de 2000 (chiffre rond) car pour l'instant, le groupe est formé dés que la somme dépasse les 2000.

En gros our l'instant ça donne cela :

Ville Nb d'employés Cumul Groupe

Paris 1500 1500 1
Los Angeles 450 1950 1
Berlin 300 2250 1
Vienne 600 600 2
Rome 1300 1900 2
Londres 400 2300 2
Amsterdam 100 100 3
New York 500 600 3
...


Et moi je voudrais cela :


Ville Nb d'employés Cumul Groupe

Paris 1500 1500 1
New York 500 2000 1
Vienne 600 1300 2
Rome 1300 1900 2
Amsterdam 100 2000 2
Los Angels 450 450 3
Berlin 300 750 3
...

Je sais que j'en demande beaucoup, désolé, je veux juste savoir si c'est possible.

Merci
Messages postés
24222
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
29 novembre 2021
6 980
Là c'est un programme du compte est bon que tu veux...
A mon avis tu auras plus vite fait de le faire à la main, d'autant plus que tu es seul à connaitre les critères de ce qui est acceptable et de ce qui ne l'est pas.
Eric
Messages postés
35
Date d'inscription
mardi 15 mars 2005
Statut
Membre
Dernière intervention
16 octobre 2008
1
D'accord, merci beaucoup pour ton aide, ça m'a beaucoup aidé et ça fera largement l'affaire.

Au revoir