Probleme de plugin sur Nagios [Fermé]

Signaler
-
 lolilol -
coucou à tous(et toutes ça m'étonnerais :s)


voila,je suis en train (d'essayer) de me servir de Nagios (sous Linux biensûr) mais j'ai un petit probleme:

je n'arrive pas à faire fonctionner le plugin "check_ping" kan je l'utilise ça me renvoie "<wrta> was not set" je ne comprends pas si kelkun s'y connais... merci d'avance

++

6 réponses

bonjour,
Je viens d'installer nagios 2.7 sous ubuntu
Mon problème est que lorsque je lance nagios par /etc/init.d/nagios start , j'ai le message suivant :
Starting network monitor: nagios
Pas de répertoire, connexion avec HOME=/
help me plz c un projet de stage
merci
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
184
Date d'inscription
mercredi 12 septembre 2007
Statut
Membre
Dernière intervention
5 mars 2009
239
Bonjour,

Pour ce problème là, il faut créer un répertoire nagios sous home.
Si ça ne suffit pas (redémarre la machine pour vérifier), cela signifie qu'il faut aussi que tu modifie ton httpd.conf qui se trouve dans /etc/apache2/
Tu trouvera ce qu'il faut mettre en recherchant l'exemple de httpd.conf qui se trouve dans le dossier où tu a extrait l'archive nagios. (si tu as suivi le tuto du site nagios, ça devrait se trouver dans /root/download/nagios.../sample-config/httpd.conf.in
essaye comme ca :
check_ping -H <ton IP> -w 100.0,20% -c 500.0,60%

bonjour,
Je viens d'installer nagios 2.7 sous Debian
Mon problème est que lorsque je lance nagios par /etc/init.d/nagios start , j'ai le message suivant :
Starting network monitor: nagios
Pas de répertoire, connexion avec HOME=/
Quand je viens dans le navigateur et je tape http:// 127.0.0.1/nagios/ j'obtient :
Forbidden

You don't have permission to access /nagios/cgi-bin/status.cgi on this server.
Je suis vraiment bloqué, j'ai besoin de votre aide pour me sortir de là.
merci
Bonjours
Pour pouvoire acceder via le browser il faut aller dans le fichier httpd.conf de apache, incluzer les lignes suivante

ScriptAlias /nagios/cgi-bin /usr/share/nagios/cgi-bin
Alias /nagios /usr/share/nagios/html
<Directory /usr/share/nagios/cgi-bin>
AllowOverride AuthConfig
Options ExecCGI
Order deny,allow
Allow from all
AuthType Basic
AuthName "Nagios"
AuthUserFile /etc/nagios/htpasswd
<Limit GET POST>
Require valid-user
</Limit>
</Directory>

<Directory /usr/share/nagios/html>
AllowOverride AuthConfig
Options Indexes FollowSymLinks
Order deny,allow
Allow from all
AuthType Basic
AuthName "Nagios"
AuthUserFile /etc/nagios/htpasswd
<Limit GET POST>
Require valid-user
</Limit>
</Directory>

si ca ne marche pas il faut l'editer dans un fichier a part nomme nagios.conf et le placer dans /etc/httpd/conf.d
fait mois signe si ça marche , à plus et bonne chance!!!
---------------------------x-----------------------------------
Toure Yssouf (javaside@yahoo.fr)
source:
http://articles.mongueurs.net/magazines/linuxmag65-bis.html#h3

bonjour ,
depuis un moment , j'ai du mal à installer une Debian sarge sur ma machine.
tout commence avec la non detection de ma carte réseau (Broadcom Netxtreme Gigabit Ethernet) et ensuite il ne reconnait pas le disque dur ; donc impossible de faire un partitionnement.
Je compte sur votre aide pour me tirer d'affaire.
Merci.
tu installe ta debian avec tous les cd ou par le reseau ??
je te conseulle par le reseau cest beaucoup plus simple

jai eu un probleme d'install par le reseau mais je lai resolu en prenant la version de debian sur debian.org

slt tout le monde
j'ai installé nagios et j'ai configuré
mais j'ai un problème nagios ag=ffiche que tout les postes down
fichier de configuration
hosts.cfg:
define host{
name generic-host
check_command check-host-alive
max_check_attempts 2
check_interval 5
active_checks_enabled 1
passive_checks_enabled 0
check_period 24x7
obsess_over_host 0
check_freshness 0
event_handler_enabled 0
flap_detection_enabled 1
process_perf_data 0
retain_status_information 1
retain_nonstatus_information 1
contact_groups serveur-admin
notifications_enabled 1
notification_interval 60
notification_period 24x7
notification_options d,r,u
register 0
}
define host{
use generic-host ; Name of host template to use
host_name virtulWin
alias poste
address xxx.xxx.xxx.xxx
check_command check-host-alive
check_command check_http
check_command check_dns
low_flap_threshold 10.0
high_flap_threshold 30.0
}

define host{
use generic-host ; Name of host template to use
host_name linux
alias Serveur
address xxx.xxx.xxx.xxx
check_command check-host-alive
check_command check_http
check_command check_dns
low_flap_threshold 10.0
high_flap_threshold 30.0
}
define host{
use generic-host ; Name of host template to use
host_name virtulRed
alias poste
address xxx.xxx.xxx.xxx
check_command check-host-alive
check_command check_http
check_command check_dns
low_flap_threshold 10.0
high_flap_threshold 30.0
}
hostgroup.cfg
define hostgroup{
hostgroup_name serveurs
alias Servers
members linux,virtulWin,virtulRed
}
contacts.cfg
# 'serveur' contact definition
define contact{
contact_name serveur
alias Nagios Admin
service_notification_period 24x7
host_notification_period 24x7
service_notification_options w,u,c,r
host_notification_options d,u,r
service_notification_commands notify-by-email,notify-by-epager
host_notification_commands host-notify-by-email,host-notify-by-epager
email nagios-admin@localhost
pager pagenagios-admin@localhost
}
contactgroup.cfg
define contactgroup {
contactgroup_name serveur-admin
alias serveurs
members serveur
}
services.cfg
# Generic service definition template
define service{
name generic-service
active_checks_enabled 1
passive_checks_enabled 1
parallelize_check 1
obsess_over_service 1
check_freshness 0
notifications_enabled 1
event_handler_enabled 1
flap_detection_enabled 1
process_perf_data 1
retain_status_information 1
retain_nonstatus_information 1
is_volatile 0
check_period 24x7
normal_check_interval 5
max_check_attempts 3
notifications if any
retry_check_interval 1
notification_interval 0
notification_period 24x7
notification_options c,r
register 0
}
define service{
use generic-service
host_name linux,virtulWin,virtulRed
service_description PING
contact_groups serveur-admin
check_command check_ping!100.0,20%!500.0,60%
}
define service{
use generic-service
host_name linux,virtulWin,virtulRed
service_description http
contact_groups serveur-admin
check_command check_http
}
define service{
use generic-service
host_name linux,virtulWin,virtulRed
service_description tcp
contact_groups serveur-admin
check_command check_tcp
}
define service{
use generic-service
host_name linux,virtulWin,virtulRed
service_description telnet
contact_groups serveur-admin
check_command check_tcp
}
define service{
use generic-service
host_name linux,virtulWin,virtulRed
service_description dns
contact_groups serveur-admin
check_command check_dns
}
merci d'avance
Messages postés
184
Date d'inscription
mercredi 12 septembre 2007
Statut
Membre
Dernière intervention
5 mars 2009
239
Bonjour,

Dans ton fichiers nagios.cfg, as-tu bien enlevé les "#" devant les lignes des fichiers que tu utilise ?
Tu doit avoir des lignes

cgi_file=/usr/local/nagios/etc/objects/commands.cfg
cgi_file=/usr/local/nagios/etc/objects/timeperiods.cfg
...
bonjour ,
j'ai un petit pblm pour nagios,
si je fais
define host {
use generic-host
......
} ça fonctionne
mais si je fais
define host {
use linux-server
......
} mon nagios ne la connait pas ! merci de m'aider
Salut,

il faut vérifier qu'il soit défini dans templates.cfg (qui se trouve probablement dans /etc/objects ou dans /usr/local/nagios/etc/objects)
Tu peux sans autre l'ajouter toi-même en fesant simplement une copie de generic-host et en la renommant (ce qui n'est pas très utile sur le coup mais qui te permettra par la suite d'apporter des modifications au template server-linux, par exemple en settant l'image à apparaître pour ce type de machine dans la map)


S'il est défini dans un autre fichier, vérifie que ce dernier soit bien intégré à la configuration de nagios par la présence de cette ligne
cfg_file=/usr/local/nagios/etc/objects/<nomFichier>.cfg
dans nagios.cfg

bomjour a tt le monde
ji un probleme sur nagiosn-3.2.0 sous red hat ji instale et tt mi ji un problem c'est que le routeru il sont detecte dans le reseu mi il sont down (eteindre ) et je si pas quoi faire s'il vous plait vous pouvez m'aidee