Modif sur formule heures de nuit [Résolu/Fermé]

Signaler
-
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
-
Bonjour à tous,

Je vous expose mon cas:

A5=(1 si travaillé et 0 si pas travaillé)
B14= heure départ
C14= heure arrivée
D14= amplitude (total heures travaillées)
E14= heures de nuit effectuées (de 21:00 à 06:00)
F14= total heures (heures hors nuit)

Ma formule d'heure est la suivante: E14=SI(ET(B14<>"";C14<>"");D14-F14;"")
Je voudrais modifier cette formule d'heures de nuit
en intégrant une variable:
Si A5=0 E14= 00:00
Si A5=1 E14=SI(ET(B14<>"";C14<>"");D14-F14;"") La formule marche

Merci de me venir encore en aide.

4 réponses

Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 117
salut
à tester : E14=SI(A5=0;"00:00";SI(ET(B14<>"";C14<>"");D14-F14;""))
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

Salut UsulArrakis,

Je viens de la tester, et le prblm reste le mm.
J'obtiens 03:00 au lieu de 00:00.
Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 117
ouaip j'ai pas le temps de tester mais essaye :
E14=SI(A5=0;"00:00";SI(ET(A5=1;B14<>"";C14<>"");D14-F­14;""))
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

le problem reste le mmm
Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 117 >
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

tu peux mettre ton fichier sur cjoint , que je puisse tester sur qqchose de tout prêt ?
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
506
Bonjour à tous,

De retour Topanini ;-)
suite de formule Heures de nuit

Si je comprend bien tu supprimes la date et tu la remplaces par 1 ou 0.
Ta formule en F4 (et non en E4 je suppose) devient:

=SI(ET(A5=1;B5<>"";C5<>"");SOMME(SI(0,875-B5<0;0;0,875-B5);SI(C5-0,25<0;0;C5-0,25));0)

tu rajoutes une condition (A5=1) et remplace "" par 0 (colonne au format heure).

mais je ne vois pas trop l'intérêt de renseigner des heures de pointage en B et en C si A=0. ;-|
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
506 >
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

Sauvegarde en version 2003
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008
>
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012

suivre ce lien:

http://www.cijoint.fr/cjlink.php?file=cj200806/cijsXAOaCi.xls
Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020
3 117 >
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

ton fichier fait seulement 10 Ko :-))))
il fallait le zipper ou le renommer en .zip cjoint n'y aurait vu que du feu
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008
>
Messages postés
7395
Date d'inscription
vendredi 28 mars 2003
Statut
Contributeur
Dernière intervention
27 octobre 2020

mon fichier en version 2003
http://www.cijoint.fr/cjlink.php?file=cj200806/cijsXAOaCi.xls
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

1 ou 0 10/05/2008 Heure Départ Arrêt Départ Arrêt Départ Heure Arrivée
Vendredi 20:30 20:50 21:00 00:10 00:23 00:30
Heure Départ Arrêt Départ Arrêt Départ Heure Arrivée
02:40 00:50 01:05 06:40

H E U R E S DE N U I T
Jour Date H. Départ H. Arrivée Amplitude H. De nuit H.hors nuit
Vendredi 10/05/2008 0:30 0:40 24:00 03:00 21:00

Mon problème est le suivant : avec le 1er tableau, je note mes heures.
Avec le 2eme je calcule mes différents temps de conduite. J'ai une formules pour les heures de nuit
mais actuellement si je ne roule pas ce jour là, le résultat est qd mm positif.
Amplitude=SI(ET(N14<>"";O14<>"");1-N14+O14;"")
H. De nuit=SI(ET(N14<>"";O14<>"");P14-R14;"")
H.hors nuit=SOMME(SI(0,875-N14<0;0;0,875-N14);SI(O14-0,25<0;0;O14-0,25)).
J'espère que mes explications sont claires.
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
506
Bonsoir.

Regarde ce classeur et dit moi si il répond à tes attentes.

A ton écoute.
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

salut chtilou,

Vraiment un grand merci pour tes lumieres.
Maintenant mon dossier est complet.
Je te tire un grand coup de chapeau, pour
ta disponibilité et ta patience M E R C I.
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
506 >
Messages postés
11
Date d'inscription
jeudi 20 décembre 2007
Statut
Membre
Dernière intervention
7 juin 2008

Contant de t'avoir rendu service.

Bon dimanche à tous.