Calcul automatique sur exel [Résolu/Fermé]

Signaler
-
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
-
Bonjour, je suis en train de creer un tableau de resultats sous exel et je veux lui faire faire un calcul automatique, a savoir si une case a une valeur comprise entre 50 et 60 (par exemple) il faudrait que la case resultat m affiche 100. une valeur comprise entre 60 70 donnera 110 .............
pouvez vous m aider merci d avance

6 réponses

Messages postés
477
Date d'inscription
mercredi 7 mars 2001
Statut
Membre
Dernière intervention
12 septembre 2016
202
=SI(A1<50;"non defini";SI(A1<60;100;SI(A1<70;110;"non defini")))
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
492
Bonjour,

autre version en 2 niveaux:

=SI(ET(A1>=50;A1<60);100;SI(ET(A1>=60;A1<70);110;"etc"))

"etc" peut être remplacé par une autre condition.
Attention maximum 7 niveaux.
merci pour votre rapidité j ai teste avec la formule

=SI(F8>=89;"215";SI(F8>=88;"200";SI(F8>=86;"170";SI(F8>=85;"142";SI(F8>=84;"124";
SI(F8>=82;"108";SI(F8>=81;"93";SI(F8>=80;"62";SI(F8>=78;"32";SI(F8>77,9;"0"))))))))

helas trop de condition donc ca me plante si vous avez une soluce merci d avance
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
492
Poste nous ton fichier ici. ;-)
>
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012

http://www.cijoint.fr/cjlink.php?file=cj200805/ciju1vcRZJ.xls.

voici le lien de mon fichier merci pour ton aide
en 2 mots si je tape 86,5 dans la cellule B4 je veux que ca me marque 170 ......
encore merci
Messages postés
477
Date d'inscription
mercredi 7 mars 2001
Statut
Membre
Dernière intervention
12 septembre 2016
202
voila une autre proposition :
http://www.cijoint.fr/cjlink.php?file=cj200805/cijzdaPpUF.xls
Dans la zone bleue, tu defini dans l'ordre croissant les intervales et les valeurs correspondantes.
La difference avec ton exemple, c'est que le dernier test devient E2>=77,9
Faudra faire quelques adaptation mais j'espere que ca repond a ton pb.
Messages postés
433
Date d'inscription
dimanche 17 février 2008
Statut
Membre
Dernière intervention
17 octobre 2008
301
Dudul,
je ne sais quel démon t'habite...
Dans ce cas, il est préférable d'utiliser une fonction RECHERCHE.
Auparavant, tu crées un petit tableau de correspondance, qui reprend bien les bornes :
Valeur / Résultat
50 / 100
60 / 110
70 / 130
etc.
Disons que ce tableau est en A1:B10 et que ta valeur initiale se trouve en C1
La formule du résultat sera =RECHERCHE(C1;A1:B10)
Pour toute valeur entre 50 et <60, le résultat sera 100 ;
pour toute valeur entre 60 et <70, le résultat sera 110;
A suivre...
oups desole pas tous compris


B -30j

% prime
AVRIL 87 142
MAI
JUIN
JUILLET
AOUT
SEPTEMBRE
OCTOBRE
NOVEMBRE
DECEMBRE




IL ME FAUDRAIT COMME VALEUR

CELULE B4(le 87%)RESULTAT (prime)en c4
>=89% = 215
>=88% = 200
>=86% = 170
>=85% = 142
>=84% = 124
>=82% = 108
>=81% = 93
>=80% = 62
>=78% = 32
<=77% = 0
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
492
Re,
regarde si ceci te convient.
>
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012

GENIAL C EST EXACTEMENT CA MERCI POUR TOUT ET A TOUS
Messages postés
1664
Date d'inscription
mardi 22 janvier 2008
Statut
Membre
Dernière intervention
30 avril 2012
492 > dudul
Contant de t'avoir rendu service.

A bientôt sur CCM. ;-)