Probleme de partage connection sous linux [Fermé]

Signaler
-
 ptitloup -
voila, j'ai poste le meme probleme sur le forum reseau et ca n'as pas abouti malgres toute la bonne volonté de " tmin"

Enfin Bref voila mon probleme (lié à linux peut etre ? )


J'ai deux pc, 1 sous xp (que j'appelle A)et l'autre a la fois sous xp et sous linux (mandrake 9.0) (que j'appelle B)


La connection est sur A, quand je met le B sous windows, le partage de connection se passe tres bien ( donc pas de prob au niveau des cables et des cartes ...)

Par contre quand je meet le B sous linux ca ne marche plus , en fait je vait sous "control center" et je regle mon reseau avec :
ip:192.168.0.2
DnS: le dns de club internet dont j'ai oublié la valeur...
Masque de sous reseau : 255.255.255.0
et passerelle:192.168.0.1


une fois cela fait, rien ne va je peut faire des pings 192.168.0.2 qui fonctionnent mais le fameu "ping 192.168.0.1" ne fonctionne pas

tout cela fait que je n'arive pas a partager ma connection

comme je n'y connait quasiment rien a linux, et ce que vous auriez des idées de commandes qui pourraieent m'aider ?

Voila Merci d'avance Florent

13 réponses

salut,
je m'y connais pas des masse nonplus mais chez moi ca fonction ;=) (désolé). Mais ta carte réseau est elle bien reconue??? Tape la commande ifconfig dans le shell en root et regarde se que tu a si tu a une interface eth0 et une adresse atribué...
Alors...
Bon, la description du pb est un peu vague...

Si j'ai bien compris, tu utilises la fonction "partage de connexion internet" de ton PC (XP).
Tout d'abord, commence par vérifier que ton PC A (qui partage la connexion) a bien 192.168.0.1 comme IP, et pas une ip DHCP qqconque.

Donc, sur PC A tu as :
IP fixe : 192.168.0.1
masque : 255.255.255.0
Passerelle : rien (tu peux en mettre une mais ca ne sert à rien dans le cas présent)
DNS : ceux de Club Internet.

Sur ton PC B (XP et Linux).
Sous Linux, je ne connais pas ton panneau de configuration, mais c'est pas bien grave.
Paramètres comme tu l'avais fait :
IP : 192.168.0.2
masque : 255.255.255.0
passerelle : 192.168.0.1
DNS : ceux de club-internet.

Valide tes paramètres, puis ouvre un terminal.
Commence par faire un "ifconfig", et vérifies que l'ip est bien celle que tu as saisie.
Ensuite, tapes "route", ce qui t'affichera la table de routage.
Tu DOIS y trouver une ligne "default 192.168.0.1 0.0.0.0 etc..."

ensuite, valides que tu peux atteindre le net en faisant un ping
genre "ping www.google.fr".
Si ca ne répond pas, essaie un ping sur une IP public (ex: ping 194.2.0.20)
Si ca répond, et que le ping de www.google.fr n'a pas marché, ca veut dire que ton paramètrage DNS n'est pas OK.
Si ca ne répond toujours pas, c'est que tu n'atteins même pas le net.

Dans ce cas, fais un "traceroute 194.2.0.20", tu dois voir apparaitre dans la liste en deuxième position l'adresse de ta passerelle....

Tiens moi au courant si ca ne marche toujours pas....
Comme maheuresment ca ne va pas je vai detaillé tout :-)

1.Verification de l'ip du pc sous windows ( alias Pc A qui fournit la connection )

Je fait un : IPCONFIG voila le resulat:

Ip:192.168.0.1
masque de sous reseau:255.255.255.0
passerelle:rien
puis plus bas c'est ecrit :
Carte PPP club :
suffixe DNS propre a la connection
IP:212.194.66.173
masque :255.255.255.255
et passerelle :212.194.66.173


2.parametrage sous linux

Je lance Control Mandrake Center (j'ai mandrake 9.0)
il me detecte mes cartes, je met:
Ip:192.168.0.2
Passerelle:192.168.0.1
Dns:194.117.200.10 (On m'as dit de mettre ca sur le forum reseau...)

Je valide
3.Le Ifconfig sous linux

Je fait Ifconfig et voila ce qu'il me donne:
etho:
inetaddrs:192.168.0.2
Bcast:192.168.0.255
mask:255.255.255.0
puis du bla bla
ensuite

lo:
inetaddress:127.0.0.1
mask 255.0.0.0

donc comme dans "etho" c'est ecrit 192.168.0.2 je suppose que c'est bon.

4.execution de route sous linux
je tape route et effectivement j'ai une ligne "default"
mais c'est ecrit:

default localhost.net 0.0.0.0 et ensuite un peu de bla bla

5.Les test de Ping
Autant etre rapide: "rien ne va" host unrecheable que ce soit un ping "google" ou ping "194.2.0.20"

6.le traceroute 194.2.0.20
je tape traceroute 194.2.0.20 et voila ce qu'il me donne :
1. pcflo(192.168.0.2) 2990.887ms !H et du bla bla

(nb: j'ai appelé mon pc Pcflo sous Mandrake control center)



7.un petit ipconfig sou mon deuxieme pc sous windows cette fois ci
Je rapelle que le pc sous linux dispose de windows et quand je le passe sous windows la connection va impec, je ne sait pas si ca peut aider mais j'ai fait un ipconfig sous windows et voila le resultat :

suffixe DNS propre a la connection :mshome.net
Ip:192.168.0.74
masque:255.255.255.0
passerelle:192.168.0.1


Voila tout ce que j'ai pu noter ca ne va toujours pas sous linux mais j'espere que ces infos feront avancer les choses :-)


Encore merci pour vos aides
Salut,

Juste une question , a l installation de la mandrake n aurais tu pas mis la config firewall sur elevee ou paranoiaque???

Dans un premier temps pour etre sur que le firewall linux ne bloque pas essaye de le couper avant de faire tes tests.( /etc/rc.d/init.d/iptables stop)

Apres reessaye le surf, le ping ;.......)

Bye
je vient de faire la manipulation pour le firewall est malheuresment ca ne change rien .
peux tu nous envoyer le resultat de la commande route -n

Merci =+
Essayes cette commande (en root) "route add default ppp0"
Je viens de mettre nimporte quoi; c'est "route add default eth0"
Messages postés
596
Date d'inscription
mercredi 31 mars 2004
Statut
Membre
Dernière intervention
3 janvier 2010
23
ta passerelle sous xp est: 212.194.66.173 met la meme à linux et tout vas marcher !!

un ane affamé avance plus vite qu'un lion repus !
quand je fait root add default eth0 il me renvoie " file exist" et c'est tout.
Quand je change la passerelle malheuresement ca ne change rien...
Pfiouuu qu'est ce qu'il faut pas entendre.
Chmod38, va falloir réviser tes cours de TCP/IP... :-)

Pour commencer, ta gateway ne peut pas etre ton interface, car
la pile TCP ne saura pas router les paquets.
Par contre, ta gateway doit bien etre ta machine windows qui partage l'acces au net. D'ailleurs, à ce sujet, tu peux bien confirmer que ta connexion est gérée par windows et que c'est pas un modem routeur que tu utilises ? D'ailleurs, juste pour info, quel est ton modem ?

Bref, revenons à ta gateway.
En shell, en root of course, tapes :
route del default
ou
route add -net 0.0.0.0 netmask 0.0.0.0 192.168.0.1
vérifie que ta route a été acceptée.

Refait tes tests de ping, traceroute etc...
Peux tu nous faire un
tracert 194.2.0.20 sur ta machine windows qui partage l'acces ?

Thanks !
Pour resumer :
A: XP avec connection internet : 192.168.0.1
B : Linux : 192.168.0.2

Dans un premier temps il te faut reussir a pinguer de B vers A.Car si ca marche pas t as beau faire ts les changement de passerelle ou autre trucs possibele , ton internet ne marchera tjs pas.

Alors Pk ca ping pas??
- As tu un firewall activée sur xp?
- As tu un firewall activée sur linux?
- As tu plusieurs carte reseau dans le linux?
- peux tu nous afficher ton route -n?

Bye
yo verifie ton nom de domaine===/// ( )
il fo kills soient pareils sous linux et XP

Bonjour à tous.

Oui oui, j'ai eu ,
exactement le même problème:

PC A: Win XP connecté ADSL 192.168.0.1
PC B: Win XP 192.168.0.2
PC C (portable): Win XP 192.168.0.3

====> Partage fichiers/imprimante/connection internet OK

MAIS, avec:

PC A: Win XP connecté ADSL 192.168.0.1
PC B: Mandrake 10 192.168.0.2
PC C (portable): Mandrake 9.1 192.168.0.3

====> Partage fichiers/imprimante (avec Samba) OK
connection internet pas OK du tout du tout du tout du tout

MAIS ALORS, le plus étrange: avec Mandrake Move (Live CD),
Knoppix (Live CD aussi), Dyne:::Bolic (toujours Live CD) en configurant
l'adresse IP en Static (192.168.0.2 sur le 2ème PC fixe et 192.168.0.3
sur le PC portable) avec DrakConnect, passerelle=192.168.0.1,
pas de valeur DNS, pas de valeur dans les serveurs mandataires,
ça marche de la balle !!! ftp, chat, surf,...tout fonctionne à mort.
Strange quand même !

La solution (après avoir fouillé et fouillé encore):
sur la machine XP (connectée à l'ADSL): clic droit
sur le bouton "Démarrer" -> Explorer tous les utilisateurs ->
Programmes -> Outils d'administration -> Gestion de l'ordinateur
choisir Services et applications -> Services
puis dans la colonne de droite double-cliquer Pare-feu de connexion internet
cliquer sur "Arrêter" et choisir "Désactivé" dans Type de démarrage.
Faire OK partout et redémarrer toutes les machines.
Là, cette fois-ci, même sous XP sur toutes les machines esclaves,
plus rien de partagé (sauf les fichiers et l'imprimante).
Bon...on réactive le pare-feu de la machine connectée en faisant la procédure
inverse. Rédémarrer toutes les machines. PC A: Win XP, PC B: Mandrake 10
et PC C (portable): Mandrake 9.1
Config manuelle comme avec les Live CD (citée plus haut)
et....ça maaaarche !!!
Je ne dis pas que c'est LA méthode de la mort qui tue la vie avec l'aide de
la grande faucheuse, mais chez moi, ça a marché seulement après
ces manipulations.
Dites-moi si chez vous ça marche.
sAlut
moi j'ai la meme config et pas de p
si je peux me permetre met 192.168.0.1 en passerelle (et oui)
et laisse ton ip fourni par ton fournisseur sur l'ordi qui sera connecte
une passerelle ou une liaison de pont est necessaire a moins d'avoir un hub
@+