Fonction si sous excel

Fermé
kesar67 - 18 mars 2008 à 17:04
 kesar67 - 18 mars 2008 à 17:47
Bonjour les gens,

voilà je me creuse la tête sur une formule,

j'ai deux résultats A1 et A2.
dans la cellule B1, je fais la différence de A1 et A2.

voilà mon soucis :
j'aimerais que dans la cellule C1, il soit écrit "il reste [résultat de la cellule B1]" si B1>0
et dans la même cellule C1, il soit écrit "il manque [résultat de la cellule B1]" si B1<0

es ce que vous croyez qu'une solution par formule peux être trouvé? et surtour laquelle?

pour le moment j'ai :
=SI(B1>0;"il reste ";"il manque ")
il me manque le résultat de B1...
:OS
merci

1 réponse

coucou,
il faut écrire :
=SI(B1>0;"il reste "&B1;"il manque "&B1)
et tu peux même faire :
=SI(B1>0;"il reste "&B1&" euros";"il manque "&B1&" euros")
0
merci pour ta réponse moi,

ça marche,... cool
mais j'ai encore un piti problème,
il m'affiche : il reste 3,70000000000005 €

même si le résultat en B1 est 3,70€

tu aurais une solution??

merci
0
en fait, c'est bon...

merci pour tout...

bonne continuation
0