FREE server et PHP?!?

Bonjour,
J'ai un site en php et html sur Free
mais ces derniers jours les pages ne souvres pas, le server de Free dis Erreur 500
Que faire S'il vous plait AIDE
en plus j'ai baucoups de visites par jours, environs 600 et je ne veux pas les decevoir
Quesque vous me proposez?
merci d'avance

5 réponses

  1. un htaccess mal configuré ?
    1. Je ne sais pas ce que s'est. il y a un mois c'etait normal, et depuis hier les page php ne s'ouvre pas,. FREE dis Eurreur 500.
      que faire?
      sinon comment configurer htaccess?
      merci baucoups
  2. Contributeur
    erreur 500:

    -probleme avec un .htaccess
    - un code php foireux peut aussi en etre la cause.

    sinon googlel est ton ami,si si.

    Erreur 500

    L'erreur 500, est une erreur de configuration d'un script cgi que vous avez déposé par ftp dans le répertoire cgi-bin. Cette erreur survient lorsque vous avez donné de mauvaise fonction dans le script. En fait le serveur va le lire et lorsqu'il trouve une erreur renvoie a la page INTERNAL SERVER ERROR

    Pour que cette page type ne soit plus affichée, vous devez créer 2 fichiers qui vous permettront de la personnaliser.
    Le premier vous l'enregistrerez sous le nom .htaccess que vous déposerez par ftp a la racine meme du serveur. Dans ce fichier vous placerez la ligne de commande suivante.
    ErrorDocument 500 http://www.votre_domaine.com/500.html

    ErrorDocument 500 = signifie au serveur que si une requete est faite a partir de votre url, et que celle-ci fournit une erreur de configuration, le serveur renvoie le visiteur vers la page que vous aurez prédéfinie
    http://www.votre_domaine.com/500.shtml = signifie la page que vous voulez voir apparaitre lors d'une telle erreur
    Remplacez: http://www.votre_domaine.com/500.html par votre propre page