Problème install phpLDAPadmin

Résolu/Fermé
xam54
Messages postés
7
Date d'inscription
jeudi 18 janvier 2007
Statut
Membre
Dernière intervention
12 mars 2008
- 5 mars 2008 à 11:05
xam54
Messages postés
7
Date d'inscription
jeudi 18 janvier 2007
Statut
Membre
Dernière intervention
12 mars 2008
- 5 mars 2008 à 16:28
Bonjour,

Dans le cadre d'un stage, je dois installer un annuaire LDAP (OpenLDAP) sur une debian et je voudrais utliser phpLDAPadmin afin de pouvoir le remplir

J'ai installé OpenLdap via la commande:

apt-get install slapd ldap-utils

Tout s'est bien déroulé apparement alors j'ai installé PhpLDAPadmin :

apt-get install phpldapadmin

et lorsque je rentre http://x.x.x.x/phpldapadmin dans mon navigateur, le message suivant apparait:

Error
Your install of PHP appears to be missing LDAP support. Please install LDAP support before using phpLDAPadmin. (Dont forget to restart your web server afterwards)

Comment s'y prendre pour le faire fonctionner ?
Merci

2 réponses

tufs
Messages postés
1272
Date d'inscription
mercredi 1 décembre 2004
Statut
Contributeur
Dernière intervention
16 mars 2008
191
5 mars 2008 à 15:12
hi ,

je sais pas si tu as deja vue le wiki suivant =>
Installation d’un serveur d’annuaire OpenLDAP ( Debian GNU/Linux )
http://aternatik.org/Installation-d-un-serveur-d,051.html
ps : apparemment il faut Apache pour faire fonctionner phpldapadmin qui est un outils du genre phpmyadmin
à voir ....
1
xam54
Messages postés
7
Date d'inscription
jeudi 18 janvier 2007
Statut
Membre
Dernière intervention
12 mars 2008
3
5 mars 2008 à 16:28
en fait j'ai résolu mon probleme en installant le paquet php4-ldap qui est le module LDAP pour php4 (il existe aussi php5-ldap)

Donc pour le moment ça tourne ;)
-1