Erreur lors du démarrage phpMyAdmin [Résolu/Fermé]

Signaler
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
-
 habib -
Bonjour,

Voila, aprés avoir fait des modif de ma config apache . (Je suppose que cela viens de la??)

Je viens de m'apercevoir que phpMyAdmin refuse de demarrer.(tous le reste semble fonctionner)

Message: Erreur lors du démarrage de la session, veuillez vérifier les erreurs indiquées par PHP ou dans le fichier témoin du serveur web, et configurer PHP correctement.

Je me souviens avoir modifié User & Group dans mon fichier httpd.conf ou j'ai mis pour les 2 nobody
mais malheureusement je ne me souvient pas des anciennes valeurs.


Lors du demarrage de httpd j'ai les erreur suivante :

[Thu Jan 31 16:22:38 2008] [notice] SELinux policy enabled; httpd running as context user_u:system_r:httpd_t:s0
[Thu Jan 31 16:22:38 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Jan 31 16:22:38 2008] [notice] Digest: generating secret for digest authentication ...
[Thu Jan 31 16:22:38 2008] [notice] Digest: done
[Thu Jan 31 16:22:38 2008] [notice] mod_python: Creating 4 session mutexes based on 156 max processes and 0 max threads.
[Thu Jan 31 16:22:39 2008] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Thu Jan 31 16:22:42 2008] [error] [client 127.0.0.1] PHP Warning: session_start() [<a href='function.session-start'>function.session-start</a>]: open(/var/lib/php/session/sess_0NLVow2p3bo4926bNxVs1asQdje, O_RDWR) failed: Permission denied (13) in /var/www/html/phpMyAdmin/libraries/session.inc.php on line 86
[Thu Jan 31 16:22:42 2008] [error] [client 127.0.0.1] PHP Warning: Unknown: open(/var/lib/php/session/sess_0NLVow2p3bo4926bNxVs1asQdje, O_RDWR) failed: Permission denied (13) in Unknown on line 0
[Thu Jan 31 16:22:42 2008] [error] [client 127.0.0.1] PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0


Merci de m'aider car je fais 2 pas en arriere a chaque fois que je progresse d'un cm...Dur dur d'etre un rookie..

7 réponses

Bonjour,

Je suis sur Windows XP avec le même problème sur phpMyAdmin. Après avoir chercher toute un après-midi en testant toutes les astuces trouvées sur internet cela ne fonctionnait toujours pas.
Heureusement je viens de trouver la solution ^^
Il fallait juste vider le cache de Firefox* pour qu'il relise le fichier config.inc.php.

Pour savoir si vous avez le même problème que moi, il suffit de passer en navigation privée sur Firefox et de lancer phpMyAdmin. Si ça fonctionne c'est que vous avez un problème avec le cache.

*Pour vider le cache de Firefox 3.5/3.6 :

Outils > Options > Avancé > onglet Réseau > Stockage hors connexion > Vider le cache maintenant.
41
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

two thumbs up :)
Impecable,
Merci
parfait merci
Merci frangin
merci bcp, ça marche bien
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
43
c bon c resolu, j'ai retrouver.

Pour user & group il fallait mettre apache dans httpd.conf
Messages postés
437
Date d'inscription
lundi 28 février 2005
Statut
Membre
Dernière intervention
24 juillet 2008
93
toujours faire des sauvegardes des fichiers de config.... ;)

Avant de l'éditer tu fait par exemple cp apache2.conf apache2.conf.old ;)

Sinon je te conseille de désintaller puis réinstaller php.... c'est le plus simple dans ton cas.
Messages postés
121
Date d'inscription
jeudi 29 janvier 2004
Statut
Membre
Dernière intervention
30 mai 2008
43
oui je sais, j'ai été un peu vite.
Bonjour je me permet de faire remonter le sujet car j'ai mis un moment à débugger ce problème.

Sous windows vérifier que le fichier host dans hdd0:\Windows\System32\drivers\etc

à bien la ligne suivante :

127.0.0.1 localhost

si vous avez autre chose pour 127.0.0.1 cela peut causer cette erreur.

Merci beaucoup pour ta réponse qui m'a permis de résoudre ce problème qui m'handicapait au travail !

=)
merci, réponse parfaite ;)