Partition ntfs [Fermé]

Signaler
-
 mattboll -
Bonjour
commencons par le début.... j'ai win xp avec une partition C: et une D: et les 2 en ntfs
depuis je me suis mis à linux (un peu )
et après renseignement j'ai l'impression que la mandrake 9.1 ne prend en compte QUE l'ecriture en ntfs je v pas rentrer dans le debat anti kro$oft mais je voulais juste savoir comment recuperer mes donnees sur linux...

ce que j'ai pensé c'est d'abord un chmod mais a ce qui parrait ca marche pas sur les partitions
ensuite j'ai lu un truc sur le mount / umount mais j'ai pas reussi a changer les droits; les options sont complexes pour des personnes comme moi...

et dernier recours part magic conversion en fat32 et la ca foir quand je reviens sur linux car non valide ou trop de mount, un truc du genre je pourrai vous renseigner un peu plus si vous desirez m'aider et que vous n'avez pas LA soluce

voila j'ai fini mon roman merci de m'avoir ecouté en esperant avoir une reponse, en attendant je v continuer de fouiller le web @++

10 réponses

Messages postés
13084
Date d'inscription
lundi 28 janvier 2002
Statut
Webmaster
Dernière intervention
28 mai 2021
418
Salut,

Tout d'abord, tout ce que tu dis au dessus me semble bien confus :)
Si tu veux recuperer tes données de windows c: d: pour les utiliser sous linux, il n'y a aucun soucis :p

Linux ne gere que la lecture des partitions ntfs.
Donc tu n'as qu'a monter tes partitions windows pour pouvoir acceder à tes données
mount -t ntfs /dev/hda1 /mnt/win_c
mount -t ntfs /dev/hda2 /mnt/win_d
(les hda1 et 2 ne sont valables que si c: et d: sont des partitions primaires. Mettons que D: soit le premier "lecteur logique" sur une partition étendue, d: correspond alors a /dev/hda5 )

Si par contre tu veux que tes données linux soient accessibles a windows, il te faudra effectivement une partition FAT32.

PS: pour tout ce qui est probleme de disque dur et de partition,
il n'est pas inutile de donner les infos suivantes:
-nombre de disque durs
-type de partition; primaire (1er, 2eme, 3eme), lecteur logique (1, 2, 3, 4, etc.) avec les letttres de lecteur correspondantes (C:, D:, E:, etc.)
-le contenu du fichier /etc/fstab

voili voilou, si je n'ai pas compris ta question, dis moi ou j'ai merdé :o)

@++



"Si c'est stupide et que ça marche,
        alors ce n'est pas stupide"
slt,
t'as compris ce qui allait pas mais pas ce que je voulais... je me rend compte que c'etait vraiment pas très clair
en fait mon problème c'est 1) avoir accès aux partitions win sans passer par le root
et 2) avoir accès à l'ecriture...


sinon j'ai un disque dur donc avec C: partition primaire
D: en logique
/ linux ext3 en primaire
et swap linux en primaire aussi

fstab:
/dev/hdb6 / ext3 defaults 1 1 
none /dev/pts devpts mode=0620 0 0 
none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-15,codepage=850 0 0 
none /mnt/cdrom2 supermount dev=/dev/hdd,fs=auto,ro,--,iocharset=iso8859-15,codepage=850 0 0 
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-15,sync,codepage=850 0 0 
/dev/hdb1 /mnt/win_c ntfs iocharset=iso8859-15,ro 0 0 
/dev/hdb5 /mnt/win_d ntfs iocharset=iso8859-15,ro 0 0 
none /proc proc defaults 0 0 
/dev/hdb7 swap swap defaults 0 0


j'oubliais, peut-être que ca peux vous aider à m'aider..., je peux convertir la partition D: en fat 32 mais comment faire pour que linux "oublie" la partition en ntfs et la retrouve en fat32 ???

merci bocoup
Messages postés
13084
Date d'inscription
lundi 28 janvier 2002
Statut
Webmaster
Dernière intervention
28 mai 2021
418
re,

Donc, prennons la ligne suivante:
/dev/hdb5 /mnt/win_d ntfs iocharset=iso8859-15,ro 0 0 

Pour autoriser les utilisateurs a la monter, il faut rajouter l'option "user"
/dev/hdb5 /mnt/win_d ntfs user,iocharset=iso8859-15,ro 0 0 

Si tu l'as convertie en fat32, il faut preciser au systeme que c'est de la fat32 et non plus du ntfs
/dev/hdb5 /mnt/win_d vfat user,iocharset=iso8859-15,ro 0 0 

Pour avoir l'acces en ecriture une fois que la partition est en fat, et reconnue en tant que telle, il faut changer le ro, (read-only) en rw (read-write):
/dev/hdb5 /mnt/win_d vfat user,iocharset=iso8859-15,rw 0 0 

Voili voilou!
@++ et tiens moi au courant!

PS: l'option "user" entraine pas mal de changement dans mount (nottament exec > noexec, suid>nosuid, dev>nodev) qui n'altere en rien le fonctionnement du systeme la pluspart du temps...
Mais au cas ou tu aurais des soucis, man mount, man fstab, et ccm biensur!

"Si c'est stupide et que ça marche,
        alors ce n'est pas stupide"
merci beaucoup ca c'est de la bonne explication, précise etc....

je v tester de suite encore merci
arrg bein ca change quasi rien j'ai modifié mounté remodifier demonté remonté

que dalle
enfin presque
mais bon j'avance on va dire....

permission denied
ca c clair net et precis

il est en fat32 je peux rentrer dedans en root
mais voila en utilisateur que dalle apres les changement de fstab
Messages postés
13084
Date d'inscription
lundi 28 janvier 2002
Statut
Webmaster
Dernière intervention
28 mai 2021
418
oki oki, bah je vais regarder ça tout a l'heure là je vais mangér :o)

@++

"Si c'est stupide et que ça marche,
        alors ce n'est pas stupide"
bah merci mais bon ct principalement pour xmule mon pb mais vu qu'en root ca marche maintenant que c en fat32 tout va bien

a moins que xmule en root soit pas une bonne idée...
Messages postés
13084
Date d'inscription
lundi 28 janvier 2002
Statut
Webmaster
Dernière intervention
28 mai 2021
418
Heu ben...
Tant qu'as faire il vaut mieux eviter de se servir de root (autant que possible :p des fois on a pas le choix (-: )
De plus Xmule c'est un log de partage de fichier sur le net non ?
Si c'est le cas, c'est a bannir pour la forme, et surtout si tu t'en serrt en root... on ne sait jamais... :)

"Si c'est stupide et que ça marche,
        alors ce n'est pas stupide"
Messages postés
13084
Date d'inscription
lundi 28 janvier 2002
Statut
Webmaster
Dernière intervention
28 mai 2021
418
alors en fait,
tu a monté ton systeme de fichier avec l'utilisateur root, et quand ton utilisateur lambda (appelons le xmule) veut ecrire dedans, tu as permission denied, c'est ça ?
Si oui, tu as plusieur solutions.
/dev/hdb5 /mnt/win_d vfat user,iocharset=iso8859-15,rw 0 0 

Aprioris, tu en est a cette ligne dans fstab.

le umask n'est pas precisé, donc il va prendre la valeur courante. (022 par défaut)
ce qui donne des droits en rwx,r-x,r-x soit 755
Ce qui veut dire que quand un utilisateur va monter la partition, toute l'arboressance
aura des droit en 755, et apartiendra a l'utilisateur qui à monté le fs.
Donc la solution qui te permet de ne rien changer, c'est que xmule monte le fs.

sinon, c'est au choix;
Soit tu veux que peut importe qui monte le fs mais en donnant des droits en lecture, ecriture, execution, à tout le monde, dans ce cas, il faut monter avec un umask à 0 -> droit rwx,rwx,rwx 777
/dev/hdb5 /mnt/win_d vfat user,iocharset=iso8859-15,umask=0,rw 0 0

Soit tu désire garder un umask restrictif (on ne sait jamais, un utilisateur qui fout le boxon c'est vite arrivé ) il faut donc faire en sorte que peu importe qui monte le fs, l'arboressance appartienne à xmule, ce qui ce fait en rajoutant uid et gid. (metons que xmule ait uid=501, gid=500)
/dev/hdb5 /mnt/win_d vfat user,iocharset=iso8859-15,gid=500,uid=501,rw 0 0 

Là, peu importe que ce soit root ou quelqu'un dautre qui monte le FS, c'est xmule le propriétaire et comme le umask n'est pas precisé, les droit sont en 755, donc xmule est le seul (et root ofcourse) a pouvoir ecrire dans l'arboressance:)

Ensuite quitte a toi de bidouiller tout ça dans tout les sens :o) c'est la meilleur façon d'apprendre !

@++
"Si c'est stupide et que ça marche,
        alors ce n'est pas stupide"
merci pour les precision je v voir tout ca mais juste un truc xmule c un logiciel comme emule si je le lance en root tout marche...

mais ca change rien, bon j'essai tout ca je redonnerai de mes nouvelles...