Calcul age excel

Fermé
monique - 15 nov. 2007 à 14:55
Raymond PENTIER Messages postés 56699 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 octobre 2022 - 15 nov. 2007 à 16:06
Bonjour, je souhaite calculer l'âge( année, et mois) d'un élève: celulle A1: date de naissance, cellulleA2: date de la visite,
merci de m'aider
monique

3 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 274
15 nov. 2007 à 15:36
Bonjour:
=ANNEE(A2)-ANNEE(A1)
Formater en nombre la cellule résultat
BCRDLMNT
4
Christounet Messages postés 1263 Date d'inscription mercredi 26 septembre 2007 Statut Membre Dernière intervention 29 juillet 2010 1 375
15 nov. 2007 à 15:10
Bonjour,

Il existe la fonction DATEDIF, tu trouveras plus d'infos en suivant le lien ci-dessous:

http://www.admexcel.com/fdates.htm

Salut,
2
Raymond PENTIER Messages postés 56699 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 1 octobre 2022 17 176
15 nov. 2007 à 16:06
Question classique ! Prends une feuille vierge et fais avec moi :

pense à saisir les dates au format jj/mm/aaa

A3 : =A2-A1 ; avec 12/11/1999 en A1 et 25/09/2007 en A2 on obtient 13/11/1907 en A3, ce qui est inexploitable en l'état
A4 : =A3, puis Format/Cellule/Nombre/Standard ; on obtient 2874, ce qui représente le nombre de jours écoulés entre les 2 dates
A5 : =A3/365,25 ; on obtient 7,87
A6 : =ENT(A5) ; on obtient 7 (c'est-à-dire 7 ans)
A7 : =A6-A5 ; on obtient 0,87 (c'est-à-dire 87 centlièmes d'année)
A8 : =A7*12 ; on obtient 10,42 (c'est-à-dire 10 mois et demi)
A9 : =ARRONDI(A8;0) ; on obtient 10 (ce qui devrait suffir comme précision)
A10 : =A6 & " ans et " A9 & " mois", en repectant les espaces dans les guillemets

Cet exercice t'ayant permis de suivre le cheminement de la démonstration,tu peux revenir à ton vrai fichier et saisir directement en A3 la formule synthétique ; mais sachant qu'on aura besoin de la durée plusieurs fois (en A5 et A6 dans notre exercice), nous allons stocker ces valeurs dans des celluless inutilisée, par exemple : J1 =(A2-A1)/365,25 et J2 =ENT(J1).

A3 : =ENT(J1) & " ans et " & ARRONDI((J1-J2) *12;0) & " mois"

Vraiment il faudra que j'en fasse une fiche pédagogique !.
1