Supprimer une bande son [Résolu/Fermé]

Signaler
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010
-
 Utilisateur anonyme -
Bonjour à tous et merci de m'accueillir sur ce site.

J'ai plusieurs vidéos avec deux bandes sons une anglaise et une française.
Comment puis je supprimer la bande anglaise?
J'ai bien virtualmod fr, j'ai même trouvé des explications pour effectuer cette suppression dans le site indiqué en fin de post.
Au moment de sélectionner le fichier vidéo à modifier il faut sélectionner dans la fenêtre d'ouverture le terme "DirectShowSource", ce que je fais. Après validation du fichier à ouvrir, une fenètre s'ouvre et dit :

" Avisynth open failure:
DirectShowSource: Ican't determine the frame rate of the video, you must use the "fps" parameter."

Si je ne met rien à la place de DirectShowSource et que je continu la procédure je supprime tous les sons de la video finale.

Mes fichiers video ont une extention AVI mais le logiciel "Gspot" m'a donné : File type: Ogg Media
Mime Type: application/x-ogg

que puis faire ????

merci pour votre aide

ufos

site de tutoriels : http://www.tutoriels-animes.com/changer-format-video.html

10 réponses


avec virtualdubmod en anglais ca donne :
Stream=>sreal list=>tu as les pistes son=>tu selectionne une et supprimer=OK
et tu ré enregistre ton film en direct copy vidéo
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010

Re bonjour et merci pour ta réponse,

C'est bien ce que je fais et cela ne marche pas? je dois faire une erreur quelque part!!!!!

ufos

c'est sur tu loupes qq chose car ca marche nickel chez moi
La piste supprimée est bien grisée (hachurée)
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010

Pour faciliter la compréhension de mon problème,est ce que je peux coller l'image de la fenêtre des flux audio. Si oui je ne sais pas comment faire , la capture en un fichier jpg de 52ko est faite.

merci

ufos
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010

En fait j'ai essayé de désactiver chacune des bandes mais à chaque fois sur le fichier vidéo enregistré, il n'y a plus de bande son, la fenêtre de la liste des flux est vide.
J'ai aussi essayé de cliquer juste sur le haut parleur de la bande français pour la sélectionner mais là aussi cela supprime tout le son sur le fichier final. Que faire ???
est ce qu'il y a un autre logiciel pour remplacer Virtualdubmod, et pour la même chose,

merci


ufos

ufos envoie moi ton image en message privé c'est le plus simple ou utilise les services de cjoint et met le lien sur le forum.
Si il y a effectivement 2 pistes on peut en supprimer une seule dans la liste tu clic droit dessus et supprimer, elle passe en hachuré
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010

Bonsoir,
Plutôt que d'envoyer l'image, ça me parait compliqué je vais tout écrire.
J'ai d'abord changé mes codec en place et remplacés par k-lite.
Je peux maintenant charger avec Virtualdbmod les fichiers en sélectionnant Directshowsource.

Dans ce cas dans la fenêtre des flux audio il n'y a plus qu'une seule piste dans laquelle il est ecrit:
Source : Input AVI file
Desc : AVI audio stream 1 [tag 0x0001], Microsoft PCM Format
Durée : 00:41001.040
Nota il n'y a rien dans la fenêtre des commentaires

Si je charge de nouveaux le fichier mais sans sélectionner "Directshowsource" le chargement du fichier se fait par une fenêtre appelée "Ogg media file import filter" Et dans la quelle il est écrit "Parsing Ogg media file".

Dans la fenêtre des flux audio il y a alors quatre pistes indiquées, deux pour l'anglais et deux pour le français (lu dans les commentaires).

piste 1 (Correspond à l'anglais)
Source : Ogg media file
Desc : OGM audio sream 1 [Vorbis], 2ch, 48000Hz, 104.0kbps
duree : 00:41:00.776

piste 2 (Correspond au français)
Source : Ogg media file
Desc : OGM audio sream 2 [Vorbis], 2ch, 48000Hz, 104.0kbps
duree : 00:41:00.584

piste 3 (Correspond au français)
Source : Oggmedia file
Desc : Ogg media file test stream 1
durée : 00:39:20.680

piste 4 (Correspond à l'anglais)
Source : Oggmedia file
Desc : Ogg media file test stream 2
durée : 00:39:20.720


C'est donc bien les fichiers ogg qui sont en cause mais comment faire je ne comprend toujours pas.

Merci HOMBOURGEOIS pour ton aide

ufos

Salut
On va essayer avec méthode : basé sur" VDM 1.5.10.2 anglais"
1-Est ce que le codec ogg est installé (vérifier avec Gspot par ex) ??
2-Gspot toujours donne bien un son codé en ogg ??
3-File/open vidéo file puis dans streams/stream list/available streams si tu clic droit sur une piste et "full processing mode" puis bouton "disable" (en bas droite) la piste passe bien en hachurée ??
4- ensuite ok pour le son et dans vidéo/direct copy et que tu fais file/save as puis enregistrer, la vidéo est elle toujours avec ses 4 pistes son ??

Donne moi les réponses aux 4 questions
Messages postés
13
Date d'inscription
lundi 5 novembre 2007
Statut
Membre
Dernière intervention
2 novembre 2010

Bonsoir,
J'ai trouvé la solution et cela marche.
En fait pour répondre à tes questions Gspot ne donne pas de codec pour ces vidéos mais c'est bien un codec ogg.
La piste passe bien en hachurée.
En fait toute manipulation sur une piste supprime le son sur la vidéo résultante.
La solution se trouve sur ce site :
http://www.sigmatek-players.com/sigmatek-pvr800-fr-guide-convertoggtomp3.htm

J'ai appliqué exactement ce qui est écrit et ça marche j'ai obtenu des vidéos avec une seule bande son en français, parfaitement synchronisée.

Je te remercie pour l'aide que tu as essayé de m'apporter. Et je ne manquerai pas de revenir sur ce forum si j'ai besoin d'aide.

ufos

je connais ce tuto, à la base c'est la même manip sauf que là on convertit un ogg en mp3 ce que sait pas faire VDM
Donc on extrait, on convertit et on réinjecte
Je mets en résolu