Excel calculer le reste en jour

hatchepsout78 Messages postés 17 Date d'inscription mardi 22 mai 2018 Statut Membre Dernière intervention 28 juin 2024 - 17 juin 2024 à 17:40
PapyLuc51 Messages postés 4356 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 13 juillet 2024 - 18 juin 2024 à 07:13

Bonjour,

Je dois faire un tableau excel (age en j), (age en année), (age en annee entière) et reste en mois. Dans la colonne, àge en annee, j'ai par exemple 49,13620808 et dans la colonne age en année entière j'ai 49. En faisant (age en année 49,13620808-age en année entière 49)×12=1,5 mois. Sauf que ça donne un chiffre négatif. Je ne comprends pas... 

Je vous remercie pour vos lumières

Isabelle.

A voir également:

4 réponses

cousinhub29 Messages postés 915 Date d'inscription mardi 10 août 2010 Statut Membre Dernière intervention 11 juillet 2024 335
Modifié le 17 juin 2024 à 18:16

Bonjour,

Avec DateDif, fonction non répertoriée dans les fonctions natives d'Excel

Bonne fin d'apm

Edit : Oupss, collision... Désolé jee pee


1
PapyLuc51 Messages postés 4356 Date d'inscription dimanche 3 mai 2009 Statut Membre Dernière intervention 13 juillet 2024 1 425
18 juin 2024 à 07:13

Bonjour à tous

Pour faire la distinction entre singulier et pluriel pour an et jour et ne rien mettre si les ans mois et jours sont à 0

La date de début en A1 - la date de fin AUJOURDHUI()

=SI(A1<>"";SI(DATEDIF(A1;AUJOURDHUI();"y")>0;DATEDIF(A1;AUJOURDHUI();"y")&SI(DATEDIF(A1;AUJOURDHUI();"y")>1;" ans ";" an ");"")&SI(DATEDIF(A1;AUJOURDHUI();"ym")>0;DATEDIF(A1;AUJOURDHUI();"ym")&" mois ";"")&SI(DATEDIF(A1;AUJOURDHUI();"md")>0;DATEDIF(A1;AUJOURDHUI();"md") & SI(DATEDIF(A1;AUJOURDHUI();"md")>1;" jours";" jour");"");"")

Cordialement

1
jee pee Messages postés 39937 Date d'inscription mercredi 2 mai 2007 Statut Modérateur Dernière intervention 13 juillet 2024 9 252
Modifié le 17 juin 2024 à 18:12

Bonjour,

Pourquoi ne pas utiliser la fonction DATEDIF() qui gère cela : https://support.microsoft.com/fr-fr/office/fonction-datedif-25dba1a4-2812-480b-84dd-8b32a451b35c

Ainsi avec une date de naissance en A1, on obtient un age en année mois jour avec la formule suivante :

=DATEDIF(A1;AUJOURDHUI();"Y")&" an(s) "&DATEDIF(A1;AUJOURDHUI();"YM")&" mois "&DATEDIF(A1;AUJOURDHUI();"MD")&" jour(s)"

La formule peut être segmentée en 3 parties distinctes si on veut les valeurs dans différentes cellules


0
brucine Messages postés 15736 Date d'inscription lundi 22 février 2021 Statut Membre Dernière intervention 14 juillet 2024 2 169
17 juin 2024 à 18:12

Bonjour,

Tu parles de reste en jours puis tu évoques un calcul en mois.

Pour obtenir les mois au format décimal il faut grossièrement multiplier le reste décimal par 365/12 mais cela n'expliquant pas pourquoi ta soustraction est négative alors qu'elle ne devrait pas l'être, on ne sait pas quels calculs tu as posés.

Exprimer un âge sous la forme 49,13620808 n'a non plus de sens, ne faut-il pas se demander quel calcul y a mené et s'il est valide?

Autrement exprimé, pour calculer un âge, il faut la date de départ et d'arrivée sur lesquelles on peut directement séparer année, jour et mois sans passer par une représentation décimale, par exemple via DATEDIF
 

0