Empêcher la veille d'un moniteur sans serveur graphique

Résolu
lenainjaune Messages postés 628 Date d'inscription mercredi 7 mai 2008 Statut Contributeur Dernière intervention 22 juin 2024 - Modifié le 18 avril 2024 à 15:42
lenainjaune Messages postés 628 Date d'inscription mercredi 7 mai 2008 Statut Contributeur Dernière intervention 22 juin 2024 - 25 avril 2024 à 14:45

Bonjour à tous :D,

Je cherche une solution pour empêcher un moniteur de se mettre en veille afin de pouvoir prendre en photo et constater les erreurs avant un gel système qui nécessite un redémarrage forcé.

J'ai essayé les commandes grub "acpi=off apm=off" de GRUB_CMDLINE_LINUX_DEFAULT sans succès, l'écran se met en veille au bout d'un moment !

J'insiste sur le fait que c'est sans serveur graphique donc ni Xorg, ni Wayland.

Merci d'avance pour vos conseils avisés.

lnj


Linux / Firefox 120.0


A voir également:

1 réponse

avion-f16 Messages postés 19249 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 15 juin 2024 4 502
20 avril 2024 à 18:55

Bonjour,

Je pense que ce comportement est contrôlé par l'option kernel "consoleblank" :

https://www.kernel.org/doc/html/v6.8/admin-guide/kernel-parameters.html?highlight=consoleblank

lenainjaune Messages postés 628 Date d'inscription mercredi 7 mai 2008 Statut Contributeur Dernière intervention 22 juin 2024 48
20 avril 2024 à 19:27

Salut ! Effectivement ça a l'air de correspondre. Je vais tester rapidement et faire un retour.

Sinon merci pour le lien ;) , je n'avais jamais lu la page des paramétrages du noyau. Je vais avoir plein d'explications sur le pourquoi du comment ...

0
lenainjaune Messages postés 628 Date d'inscription mercredi 7 mai 2008 Statut Contributeur Dernière intervention 22 juin 2024 48 > lenainjaune Messages postés 628 Date d'inscription mercredi 7 mai 2008 Statut Contributeur Dernière intervention 22 juin 2024
Modifié le 25 avril 2024 à 14:47

Je confirme que ça fonctionne comme attendu :D !

A noter que dans mon cas (Debian 9) :

  • depuis /etc/default/grub, ajouter à la ligne GRUB_CMDLINE_LINUX_DEFAULT le paramètre consoleblank=SS où SS est la durée avant mise en veille exprimée en secondes
  • le fichier modifié est /sys/module/kernel/parameters/consoleblank
  • on peut configurer à la volée avec setterm -blank MM où MM est la durée exprimée en minutes (pour setterm bien que l'utilisation du double tiret est possible depuis la v2.25, il est conseillé d'utiliser le simple tiret pour la rétrocompatibilité) - source

Donc nickel, problème résolu !

1