Impossible de taper @ dans virtualbox

Résolu/Fermé
sympatiqueCCM Messages postés 358 Date d'inscription jeudi 5 octobre 2006 Statut Membre Dernière intervention 26 juin 2023 - Modifié le 13 janv. 2023 à 16:06
mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 - 13 janv. 2023 à 16:02

Bonjour,

J'ai installer une machine virtuelle linux version de Debian (KaliLinux  pour white hat) sous virtualbox.

Tout fonctionne, mais je n'arrive pas à taper certains caractères, comme le caractère @ 

Comment fait-on ?

Merci beaucoup de votre aide,

A voir également:

6 réponses

mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 7 748
11 janv. 2023 à 10:09

Bonjour,

Concernant ton erreur APT, c'est probablement parce que tu n'as pas lancé sudo apt update récemment.

Concernant ton problème de clavier, ça pourrait être la KEYMAP qui n'est pas la bonne (uk au lieu de us, voir cette page). Si c'est le cas, il faudrait corriger /etc/default/keyboard :

sudo apt update
sudo apt install console-setup
sudo nano /etc/default/keyboard

... puis une fois le fichier /etc/default/keyboard corrigé (ctrl x, o, entrée pour sauver et quitter) :

sudo dpkg-reconfigure keyboard-configuration
sudo service keyboard-setup restart

Plus de détails ici.

Bonne chance

1
mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 7 748
10 janv. 2023 à 15:12

Bonjour,

  • Es-tu en mode console ou dans une application particulière (terminal, navigateur, client mail) ?
  • Quelle combinaison de touches presses-tu pour tenter d'écrire @ ?
  • Quelle disposition de clavier utilises-tu ? azerty ou qwerty ?

Bonne chance

0
sympatiqueCCM Messages postés 358 Date d'inscription jeudi 5 octobre 2006 Statut Membre Dernière intervention 26 juin 2023 11
Modifié le 13 janv. 2023 à 16:08

Merci beaucoup mamiemando,

Je suis sur un clavier qwerty et le caractère @ est situé en haut du chiffre 2, donc Shift + 2

Mais j'ai aussi essayé toutes les autres touches en minuscule ou en Majuscule (SHIFT) mais jamais le caractère @ n'apparaît.

Je suis dans ce que kali linux appelle l'Émulateur de terminal.

J'ai essayé :

dpkg-reconfigure locales 

Et j'ai essayé :

sudo apt install console-setup

... et ça n'a rien n'a changé.  Des erreurs sont apparues dans cette commande 

0
sympatiqueCCM Messages postés 358 Date d'inscription jeudi 5 octobre 2006 Statut Membre Dernière intervention 26 juin 2023 11
Modifié le 12 janv. 2023 à 13:22

Merci pour ton aide.

J'arrive pas a éditer le fichier keyboard.  Je pointe avec ma souris mais 

Je n'arrive pas a écrire dans le fichier.  Je voudrais remplacer "ca" par "us" mais ça ne fonctionne pas.

J'ai inclue sudo dans la commande...   c.a.d. :

sudo nano /etc/default/keyboard

Ce que j'ai dans le fichier keyboard :

# Consult the keyboard(5) manual page.

XKBMODEL = "pc105"
XKBLAYOUT="ca"
XKBVARIANT=""
XKBOPTIONS=""
BACKSPACE="guess"
0
mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 7 748
12 janv. 2023 à 13:23

nano ne supporte pas la souris, et fonctionne purement au clavier. Utilise les flèches de ton clavier.

0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
sympatiqueCCM Messages postés 358 Date d'inscription jeudi 5 octobre 2006 Statut Membre Dernière intervention 26 juin 2023 11
12 janv. 2023 à 20:48

Merci mamiemando,

Avec les flèches du clavier ça très bien fonctionné.  J'ai pu inscrire "us" dans le fichier keyboard.

La j'ai un problème avec sudo dpkg-reconfigure keyboard-configuration.

Je comprend pas trop trop...

0
mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 7 748
Modifié le 13 janv. 2023 à 16:03

La première ligne de ton fichier /etc/default/keyboard me paraît bizarre, on dirait qu'il manque le #. C'est probablement pour ça que sudo dpkg-reconfigure keyboard-configuration a planté, mais il faudrait si le problème persiste me reporter le message d'erreur. Merci d'éviter les captures d'écran et de privilégier les copier coller (sous Linux, et notamment dans un terminal qui lance nano, tu peux sélectionner du texte, le copier, et le coller ailleurs).

0
sympatiqueCCM Messages postés 358 Date d'inscription jeudi 5 octobre 2006 Statut Membre Dernière intervention 26 juin 2023 11
Modifié le 13 janv. 2023 à 16:02

Merci mamiemando,

C'est résolu. J'ai ajoute un # au début de la première ligne et elle est devenu imprimé en bleu.

Ensuite j'ai fait sudo dpkg-reconfigure keyboard-configuration et répondu aux questions, et maintenant, ça fonctionne bien.

Vraiment tu connait bien linux...!

Merci encore mille fois de ton aide.

0
mamiemando Messages postés 33077 Date d'inscription jeudi 12 mai 2005 Statut Modérateur Dernière intervention 18 avril 2024 7 748
Modifié le 13 janv. 2023 à 16:04

Félicitations et merci du compliment :-) Voici comment basculer ton sujet en résolu pour les prochaines fois.

Bonne continuation ! 

0