Recherche de mots

Signaler
-
Messages postés
54273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
-
Bonjour,

Via une formule, je veux retrouver dans plusieurs cellules contenant du texte, celles qui contiennent le mot "amas" en captant aussi "(amas)", mais sans capter "ramasser".

Merci
Nathalie

4 réponses

Messages postés
54273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
16 245
Bonjour Nathalie.

Formule unique
=NB.SI(A2;"* amas *")+NB.SI(A2;"* (amas) *")

Messages postés
17406
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 juillet 2021
4 664
Bonjour,

ou comme cela

=NB.SI(A1:A10;"*amas*")-NB.SI(A1:A10;"ramasser")
Messages postés
13057
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 juillet 2021
2 217
Bonjour à tous

Il me semble que Nathalie ne veut pas dénombrer ses "amas" mais trouver les cellules contenant ce mot seul à l'aide d'une formule.

Il serait possible par une mise en forme conditionnelle de colorer les cellules contenant amas seul.

Pour ma part j'ai prévu une fonction personnalisée qui retourne les adresses des cellules dans lesquelles on retrouvera le mot cherché non précédé ou suivi immédiatement par une lettre (majuscule ou minuscule) pour exclure les ramasser, amasser, lamas etc mais prendre en compte les (amas), comme les amas, ou les amas.
https://mon-partage.fr/f/DGhi4yhO/

Cdlmnt
Via
Messages postés
54273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
16 245
Salut, cher ami Via.

Dans ma proposition, à chaque ligne j'affiche 1 ou 0 selon que dans la colonne A la cellule contienne ou non le texte " amas " ou " (amas) " comme le souhaite Nathalie.
Elle n'a pas spécifié que ce mot soit seul dans la cellule.

Cordialement.
Messages postés
13057
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 juillet 2021
2 217
Salut mon cher Raymond ☺

Oui je suis peut être allé un peu vite en voyant les NB.SI et en concluant dénombrement
Ton tableau indique bien (mais de façon pas très claire) si on trouve amas ou (amas) mais à la ligne 4 il met deux 0 comme pour ramassis de ligne 2 alors qu' "amas est censé être bon je pense , non ?

J'ai bien acté que le mot n'est pas forcément seul dans la cellule
Regarde le fichier que j'ai joint, amas n'est pas seul

Je me suis mal exprimé, je voulais dire que amas n'est pas compris à l'intérieur d'un autre mot comme ramasser, mais amas (amas) "amas" amas, amas! etc devraient être il me semble relevés comme bons d'où ma fonction personnalisée pour vérifier qu'aucune lettre ne précède ou ne suit immédiatement amas dans la chaîne auquel cas ce serait un autre mot dont il fait partie

Bien cordialement
Messages postés
54273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juillet 2021
16 245 >
Messages postés
13057
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 juillet 2021

Notre amie Nathalie a voulu se montrer précise ; malheureusement elle ne l'a pas été suffisamment ; c'est pourquoi je lui ai proposé mon tableau pour qu'elle ait l'opportunité de confirmer ou corriger ; mais j'attends toujours !